This site is not loaded/shown correctly. Navigator window is completely blank, no errors reported.

RESOLVED WORKSFORME

Status

()

Core
Networking
--
major
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: Max Alekseyev, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
Linux build 2004072806

Open provided URL. Mozilla shows blank page, no errors reported.
Mozilla 1.5 release loads and shows this site fine -> regression.

Comment 1

14 years ago
Loads fine with 1.7.1 on WinXP.
> Mozilla 1.5 release loads and shows this site fine -> regression.

It doesn't load it fine over here... In fact, none of the Mozilla builds I have
here (going back to fall of 2001) show the site.

And that's not surprising -- the site sends back the following headers:

16386[80ef918]: http response [
16386[80ef918]:   HTTP/1.1 200 OK
16386[80ef918]:   Server: Microsoft-IIS/5.0
16386[80ef918]:   Date: Thu, 29 Jul 2004 16:00:26 GMT
16386[80ef918]:   Content-Type: text/html
16386[80ef918]:   Set-Cookie: ASPSESSIONIDQQSRCDBS=LGBPGEJDGKBCFEEMIFGOHBME; path=/
16386[80ef918]:   Cache-Control: private
16386[80ef918]:   Content-Encoding: gzip
16386[80ef918]:   Transfer-Encoding: chunked
16386[80ef918]:   Vary: Accept-Encoding
16386[80ef918]: ]

but doesn't send valid gzip content along with the headers, looks like (the gzip
decoder in Mozilla throws an exception on the data).

Comment 3

14 years ago
I just re-checked: it probably works for me because I'm using a proxy.
On Linux this also works - as long as I'm using the proxy. If I'm not the page
stays empty as described.

Max, could this also be why it works for you with Mozilla 1.5? (different proxy
settings)
(Reporter)

Comment 4

14 years ago
> Max, could this also be why it works for you with Mozilla 1.5? (different proxy
> settings)

I did not test myself. But I asked on irc://freenode/debian-russian and got at
least two confirmation that everything works fine: with 1.5 and 1.2.1 releases.
I am not sure if they used proxy though. I am going to clarify that.

I've just got confirmation that the page is not loaded by Mozilla OS/2 release 1.7.
OS: Linux → All
Hardware: PC → All
(Reporter)

Comment 5

14 years ago
(In reply to comment #2)

> And that's not surprising

In any case the browser should report something to user, shouldn't it?
For example, Konqueror reports the following:

An error occurred while loading http://www.skiminok.ru/:
Receiving corrupt data.

BTW, Links browser renders the page fine. No other browsers here to try.
(Reporter)

Comment 6

14 years ago
It seems that Mozilla (any version) is able to render the page only when proxy
is in use.
Removing 'regression' keyword.
Keywords: regression
Product: Browser → Seamonkey
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

13 years ago
current trunk shows an XUL error page:

Cannot Complete Request

The page you are trying to view cannot be shown because it uses an invalid or
unsupported form of compression. Please contact the website owners to inform
them of this problem.

==> HTTP
Assignee: general → darin
Component: General → Networking: HTTP
Product: Mozilla Application Suite → Core
QA Contact: general → networking.http

Comment 9

13 years ago
I see the same error message reported by the previous poster on the site

http://www2.informatik.uni-wuerzburg.de/

It works with RC3 of Firefox 1.5 but not with current nightly of Firefox 1.6 or current nightly of Camino (all tests done on Mac OS X).

Comment 10

12 years ago
-> default owner
Assignee: darin → nobody
Component: Networking: HTTP → Networking
QA Contact: networking.http → networking

Comment 11

11 years ago
Cannot reproduce with 'wget -d -O /dev/null --header="Accept-Encoding: gzip, compress"' -- perhaps the site has disabled compression.
(Reporter)

Comment 12

11 years ago
The bug seems to have gone.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.