Better Display of past dates and present day

VERIFIED DUPLICATE of bug 416802

Status

--
enhancement
VERIFIED DUPLICATE of bug 416802
14 years ago
11 years ago

People

(Reporter: christoff_pale, Unassigned)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

Hi,
I have a habbit of crossing out days on my paper calendar, so that
I know that I have accomplished what I had planned to do on that
particular date. I find that the calendar (sunbird) does not have
a good highlighting of the present days and the days that have passed
(this is essentially a request for better color schemes -- perhaps
could be taken care by themes).
Secondly, I want to request if the user can choose to decorate 
previous dates with some emblems. For example, I would like to put
a Big "X" on the days that have passed (i.e. if today is the 29th
then I want to put "X"s on all the days of the month till the 28th)
thanks


Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Updated

13 years ago
QA Contact: gurganbl → sunbird

Comment 1

13 years ago
Maybe this could be accomodated by adding an attribute relative-time="past",
="present", ="future", then themes could style past, present (overlapping with
now), and future boxes differently.

One issue is that this attribute would not automatically change at midnight. 
This would be even more an issue if the same approach was consistently applied
to hour boxes in day and week view, or event boxes in all views.  (Maybe add a
timer that refreshes the display once an hour or at the end of an event.  A
problem with this is it could interfere with what the user is doing.)

Comment 2

13 years ago
*** Bug 268040 has been marked as a duplicate of this bug. ***
Reassigning all automatically assigned bugs from Mostafa to nobody@m.o

Bugspam filter: TorontoMostafaMove
Assignee: mostafah → nobody
Component: Sunbird Only → Calendar Views
QA Contact: sunbird → views
Taken care of in bug 416802. See http://img207.imageshack.us/img207/430/bug416802vv4.png for an example image.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 416802
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.