long hang with non-responding UI is caused by stalled server

RESOLVED WORKSFORME

Status

()

defect
--
critical
RESOLVED WORKSFORME
15 years ago
11 years ago

People

(Reporter: rn214, Unassigned)

Tracking

({hang})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040514
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040514

Sometimes, when opening a link, the UI becomes totally un-responsive. The
rotating "loading" icon in the tab stops moving, and it is impossible to close
the tab, read another tab, switch to e-mail, etc. The window doesn't repaint.
The CPU load is 0, and mozilla will *eventually* recover after several minutes,
but its usually easier to forcibly kill mozilla and restart. 

This is an intermittent problem, ocurring on many sites, but never repeatably.
Even shift-reload on the same page that caused a hang will not make it repeatable. 

Reproducible: Sometimes
Steps to Reproduce:
I finally found a repeatable case: http://ex-mozilla.org/date.html
(which is also ideal, since it doesn't have any weird stuff in it like
javascript,flash etc). This page was slashdotted yesterday, and the server was
really suffering. As a result, I found that the hang in mozilla was repeatable.
[Konqueror told me it was transferring data at 169 bytes/sec before stalling in
the same way, although it did time-out after about 15 sec.]

This leads me to guess that the random, non-repeatable lockups that happen on
sites such as theregister.co.uk are caused by an embedded advert, where the
advertising server, such as doubleclick, is struggling. A [shift]-reload will
result in a different advert, or a different "load-balanced" server for the
advert, hence this is non-repeatable. Installing "Adblock" has reduced the
incidence of this bug for me.


Expected Results:  
Mozilla should time-out much sooner on a stalled server. It should also try to
do the networking stuff "in the background" so that such a stall can never cause
the UI to freeze for so long. It should be at least possible to force a timeout
using  eg "Esc-Esc". 

See also:
   Bug 249638
   Bug 183122
which I think are releated.

I have also (more rarely) seen moz freeze up at 100% CPU load, but I think
that's a totally different issue.)

(Could this be the first time a slashdotting has fixed a bug?!)

Updated

15 years ago
Keywords: hang

Comment 1

14 years ago
I see similar behavior on the Mac, FF 1.5B1.  It seems to occur after DNS lookup
(because long DNS queries don't hang FF).  It seems to always happen before any
of the page content is displayed (i.e. while the previous page is still
visible).  The corresponding tab displays "Loading" and the spinning progress
indicator doesn't move.  I'm on a terrible network and so this happens quite often.
Reporter

Comment 2

14 years ago
I still find this occurs with current versions of Mozilla-suite, most notably on
e-bay (where it happens on almost every page-load - the browser "locks up"
completely for 5-10 seconds). 

However, installing ad-block cures this in most cases. 

I don't really object to loading web adverts (at least, not while I am on a fast
connection), but I really draw the line at adverts served up by an overloaded,
and non-responding advert-server which make my browser lock up!

Comment 3

14 years ago
I am using Firefox 1.5 and I got the same problem:

When loading a page it randomly happens, that Firefox seems to have crashed. (Same symptoms as already described above) The problem appeared not before version 1.5!


Extensions:

FlashGot 0.5.9.99
Adblock Plus 0.5.11.1
Adblock Filterset.G Updater 0.2.6
Flashblock 1.5
Fasterfox 1.0.1
Minimize to Tray 0.0.1.2005091606+
Tabbrowser Preferences 1.2.8.8
Sendmeffile Torrent Toolbar 1.0.1.0
DownThemAll! 0.9.8.4
googlebar 0.9.15.07
IE Tab 1.0.6.4
NoScript 1.1.3.5
URL Alias (patched for FF 1.5) 1.02

No Theme is used!


Furthermore: My system has recently be reinstalled, so it is not a problem with windows.
Reporter

Comment 4

13 years ago
netstat reports that the connection is in the CLOSE_WAIT state. 

[Aside: if you wait for ages, (a few minutes), mozilla will usually un-hang - I can't tell whether this is because mozilla does eventually time-out (after far too long), or whether the offending server has eventually responded]

Does that help?

Comment 5

13 years ago
people reporting this problem on macosx can use activity monitor, select their gecko and click the sample button when it happens. save that log to a file and attach it here.
Summary: long hang, apparent crash with non-responding UI is caused by stalled server → long hang with non-responding UI is caused by stalled server

Updated

13 years ago
Assignee: darin → nobody
QA Contact: benc → networking
This can not be reproduced, resolving
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME

Comment 7

11 years ago
My Firefox 3.0.6 occasionally stopped responding a few hours ago with 100% cpu usage and Process Explorer showed about 3 active NSSWF dlls + more active NT getdatetime or such right below the main Firefox thread.

Comment 8

11 years ago
This page, opened in a tab from a Bugzilla search result, in an otherwise tabless window, failed to come in focus for minutes or more as i took this process graphic. No cursor loading indication, but the search page had a full page loading progress bar, as does this only tab in a new window. Firefox 3.0.6 on Windows XP.
You need to log in before you can comment on or make changes to this bug.