input outside form submitted with form

RESOLVED DUPLICATE of bug 182824

Status

()

RESOLVED DUPLICATE of bug 182824
14 years ago
13 years ago

People

(Reporter: pawlowski, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040729
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040729

Weird case -- the example above was as minimal as I could get it.

Form contains two inputs, after form there is some JavaScript to set focus to an
element in the form, then there is another input floating around. Around the
form and input there is a FONT tag.

When this form is submitted, all three inputs are included in the query string

Reproducible: Always
Steps to Reproduce:
1. click submit

Actual Results:  
query string contains three cgi params -- includes one that isn't contained in
the submitted form.

Expected Results:  
two cgi params submitted -- only the ones in the form.

workarounds:

 - put <form /> around formless input
 - move <script /> node to after formless input
 - remove FONT tag around code
<font> isn't allowed to contain <form>, so the parser starts doing fixup.  In
the middle of the fixup the script flushes the content model.  The upshot of all
this is that the last <input> ends up a child of the <font> which ends up a
child of the <form>.

Over to parser, but I doubt we'll be changing this behavior much.  Residual
style fixup is tricky as it is, and this works correctly with valid HTML, so....
Assignee: form-submission → parser
Component: HTML: Form Submission → HTML: Parser
Confirming, because this is a bug, but as Boris said, it probably will not get
fixed. (Maybe I should just mark this WONTFIX?)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Related to, or dupe of, bug 182824 ?

*** This bug has been marked as a duplicate of 182824 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.