syracuse.com - [LAYER] Entire web site doesn't render well

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
P3
normal
RESOLVED FIXED
18 years ago
3 years ago

People

(Reporter: Scott Springer, Unassigned)

Tracking

Details

(Whiteboard: [PROPRIETARY-HTML] [havecontact] [bug248549notfixed], URL)

(Reporter)

Description

18 years ago
Summary is pretty self explanatory!  Links won't work, pieces don't show up in
the right places, etc.

For example, there is a menu (probably javascript) at the left of the page.  The
menu items don't show up there like they are supposed to, but they render at the
bottom of the page.  Hard to describe - easy to understand when you see it.

Also, you place your mouse pointer over a link and the icon doesn't change.  You
click on it and you don't go anywhere.  It doesn't seem to want to recognize the
links on the page.

Front page might work.  Surf around on site and see what happens.

Comment 1

18 years ago
Confirmed with 2000-01-31-08-M14 on Windows NT 4.0.

This page does have serious problems with its javascript-driven menus.

Anybody want to try reducing this to a testcase before this gets passed to
one of the "DOM" components. There is no document.layers here but I can't vouch
for the js otherwise.

Links above the sidebar menu that it messing up do work, the rest don't,
whatever "column" they may be in, so that problem is probably secondary to the 
js problem.

Comment 2

18 years ago
Assigning all open "nobody@mozilla.org" bugs to "leger@netscape.com" to weed 
thru.
Assignee: nobody → leger

Comment 3

18 years ago
This is a css bug (Absolute Positioning)

The line:
<DIV ID="NAVSPAN" STYLE="position: absolute; top: 195; left: 10">

causes all links on the right-hand side not to work as long as the left-hand
menu table is created (when it ends, links below it work).

Taking out "position: absolute" makes all the links work
Status: NEW → ASSIGNED
Component: Browser-General → Style System
Keywords: css1

Comment 4

18 years ago
Updating QA contact to match component. Not sure which of the 17 other 
"absolute pos" bugs this is going to be a DUP of...
QA Contact: nobody → chrisd

Comment 5

18 years ago
Reassign to component owner.
Assignee: leger → pierre
Status: ASSIGNED → NEW

Comment 6

18 years ago
The part about the links not working in an absolutely positioned DIV is a dup of 
bug 24474 which both looks very similar and acts the same. 

The JS menu bugs are another story altogether.

Comment 7

18 years ago
Taking over 1/3 of Pierre's NEW bugs to help reduce his doomage factor
Assignee: pierre → attinasi

Comment 8

18 years ago
Reassigned back to me these bugs that shouldn't have left my list.
Assignee: attinasi → pierre

Comment 9

18 years ago
JS menus don't work because they rely on layers (which are no longer supported).
Reassigned to ekrock to evangelize the webmaster.
Assignee: pierre → ekrock
Summary: Entire web site doesn't render well → [layers]Entire web site doesn't render well
INVALID. LAYER, ILAYER, document.layers[] not supported in Gecko/Nav6. Closed. 
Notified reporter and site owner via template at 
http://sites.netscape.net/ekrock/fixit/layer.html
In the future, if possible, please INVALID, notify, and close such bugs directly 
using that template without assigning to me. Thanks!
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
Summary: [layers]Entire web site doesn't render well → [LAYER] Entire web site doesn't render well

Comment 11

18 years ago
Verified invalid
Status: RESOLVED → VERIFIED
Moving all [LAYER] bugs to Evangelism component for tracking and open-source
evangelism by mozilla community members of sites that need to upgrade to support 
web standards such as HTML 4.0 (instead of LAYER/ILAYER) and the W3C DOM
(instead of Nav4 document.layers[] or IE document.all()). Sites should be
lobbied to do the upgrade using the email templates that are linked to from
http://www.mozilla.org/newlayout/bugathon.html#layerbugs . When a site's owner
has confirmed receipt of the message requesting an upgrade, the bug should be
marked with the keyword evangelized to indicate that evangelism for that bug is
complete. When the site finishes the upgrade and supports standards, the bug
should be closed.
Assignee: ekrock → nobody
Status: VERIFIED → NEW
Component: Style System → Evangelism
Keywords: evangwanted
QA Contact: chrisd → nobody
Marking bug evangelized and clearing cc:s as courtesy to reduce spam.
Keywords: evangelized
Resolution: INVALID → ---

Comment 14

18 years ago
SPAM:Changing QA contact on 111 evang bugs as I am now the new QA contact for 
this component.

Sorry about the spam

zach
QA Contact: nobody → zach

Comment 15

18 years ago
Reassigning Evangelism bugs to me, the component's new owner.  I would like to 
take this opportunity to thank nobody@mozilla.org for all of his dedication, 
contributions, and hard work, and wish him luck at his new job.  Thanks, nobody.
Assignee: nobody → BlakeR1234

Comment 16

18 years ago
Removing the evangwanted keyword from 49 evangilizm bugs that also 
have the evangelized keyword. Having both of these keywords on a bug 
makes it really hard to do a query for all open evangilizm bugs that are 
evangwanted. Sorry for the spam.
Keywords: evangelized

Comment 17

17 years ago
Sorry about this problem. I somehow screwed up the keyword changes. 
Sorry about this spam.
Keywords: css1, evangwanted → evangelized

Comment 18

17 years ago
-> evangelism@telocity.com for my evangelism bugs.

removing the now-depreciated evangelism-related keywords.

setting platform to All.
Assignee: blakeross → evangelism
Keywords: evangelized
Hardware: PC → All

Comment 19

17 years ago
Reassigning evangelism bugs to bclary@netscape.com.
Assignee: evangelism → bclary

Updated

17 years ago
Summary: [LAYER] Entire web site doesn't render well → syracuse.com - [LAYER] Entire web site doesn't render well

Comment 20

17 years ago
evangelized site using layer letter tool.

Zach
Assignee: bclary → zach
Whiteboard: [PROPRIETARY-HTML]

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 21

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 22

16 years ago
site has been fixed in bits from 11/10. RESOLVED FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago16 years ago
Resolution: --- → FIXED

Comment 23

16 years ago
sorry, not fixed.
Error: document.NAVSPAN has no properties
Source File: http://www.syracuse.com/dhtml/hnavbar/scripts/hGlobal.js
Line: 9

Error: top_coord is not defined
Source File: http://www.syracuse.com/dhtml/hnavbar/scripts/hData.js
Line: 1

Error: hNAVBAR has no properties
Source File: http://www.syracuse.com/
Line: 398
Status: RESOLVED → REOPENED
QA Contact: zach → bclary
Resolution: FIXED → ---

Updated

16 years ago
Whiteboard: [PROPRIETARY-HTML] → [PROPRIETARY-HTML][aok]
-> moi
Assignee: zach → doronr
Status: REOPENED → NEW
OS: Windows NT → All
http://www.nexgenmedia.net/evang/syracuse.com/www.syracuse.com.html is the fixed
version (only menus)

contaced via webform
Status: NEW → ASSIGNED
Whiteboard: [PROPRIETARY-HTML][aok] → [PROPRIETARY-HTML][contact[
Target Milestone: --- → Feb
positive responce. he even asked me to look into his personal site's dhtml :)

Comment 27

15 years ago
looks like the site got a mayor js free redesign to me ... WFM
menus still broke
Status: ASSIGNED → NEW
Target Milestone: Feb → ---

Comment 29

15 years ago
tech evang june 2003 reorg
Assignee: doron → english-us
QA Contact: bc → english-us

Comment 30

14 years ago
maybe its just me but I can't find any broken menu's on syracuse.com,

and a side note, Syracuse needs better recruiting, there College football team
stinks, maybe a standards compliant website will help that out.

Comment 31

14 years ago
Warning: The stylesheet http://www.syracuse.com/css/home.css was loaded as CSS
even though its MIME type, "text/plain", is not "text/css".

Warning: The stylesheet http://www.syracuse.com/css/hp.css was loaded as CSS
even though its MIME type, "text/plain", is not "text/css".

Error: SuperBannerFlash is not defined
Source File: http://www.syracuse.com/
Line: 57

Error: document.NAVSPAN has no properties
Source File: http://www.syracuse.com/dhtml/hnavbar_class/scripts/hGlobal.js
Line: 9

Error: top_coord is not defined
Source File: http://www.syracuse.com/dhtml/hnavbar_class/scripts/hData.js
Line: 2

Error: hNAVBAR has no properties
Source File: http://www.syracuse.com/
Line: 448


Considering I am in Central VA, no wonder the Hokies beat the crap out of them. :-)

Comment 32

14 years ago
Whoops my bad, i forgot to look at the Java Script console, I was looking for
tactile errors and such :) I didn't scratch the surface.

Virgina Tech deserves to keep there #4 ranking

Comment 33

14 years ago
I just found the drop down recipeint selector for the Syracuse.com feedback, fourm
will not drop down. under Mozilla or Firebird

Comment 34

14 years ago
Correction I meant to type Will drop down in Mozilla but not firebird

Comment 35

14 years ago
Site has changed considerably, do any of these bugs still exist?  If not, should
be bug be closed?
drop down menuw still not working
Whiteboard: [PROPRIETARY-HTML][contact[ → [PROPRIETARY-HTML] [havecontact] [bug248549notfixed]

Comment 37

10 years ago
I don't see any drop-down menus at all any more. I'm going to resolve this FIXED. If there are any more problems, please file new bugs for them.
Status: NEW → RESOLVED
Last Resolved: 16 years ago10 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.