onLoad event of SVG is not working properly with Mozilla build Id: 2004072509

RESOLVED WORKSFORME

Status

()

Core
SVG
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Radha Kameswari, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a3) Gecko/20040725
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a3) Gecko/20040725

onLoad event of SVG is firing only once.With each reload its not firing SVG
onLoad event. Its firing only if all contents in Mozilla catche folder are removed.


Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

13 years ago
Could you give a testcase?  The onload on the following document appears
to be firing at each reload:

  http://www.croczilla.com/~alex/testcases/onload.svg
WORKSFORME, but I encountered this problem a few weeks ago. I was busy with
other things so I didn't persue it at the time and it disappeared shortly
afterwards. I have been constantly rebuilding and I created new profiles several
times around about then, so doing the same will hopefully fix this problem for
you also. I would suggest you download a more up to date version of mozilla
first, and then try a new profile. Once you've done that please comment here to
let us know what did or didn't work for you. 

Comment 3

13 years ago
WORKSFORME. Checked with 
Mozilla 1.8a3
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a3) Gecko/20040808
For each refresh of the testcase provided (
http://www.croczilla.com/~alex/testcases/onload.svg) the onLoad event was fired.
OP can you please check with the above mentioned build and confirm the result ?

Comment 4

13 years ago
It doesn't seem to work for me. I tried creating a new profile, but that doesn't
solve the problem.
I've already tried the testcase but also that doesn't work after reloading.
I'm using Mozilla 1.8a3, latest build. 
Have you installed Adobe's SVG Viewer plugin for Mozilla? 

Comment 6

13 years ago
I've installed Adobe SVG Viewer 3.01. I can view SVG images, so that is not the
problem. The problem is that the onLoad event is only fired once, not after
reloading.
Actually I was suggesting that having ASV installed could be the problem. Sorry,
that wasn't very clear. Please try with a version of Mozilla built with *native*
SVG support (see http://www.mozilla.org/projects/svg/). ASV does not work very
well with Mozilla. 

Comment 8

13 years ago
I downloaded a Mozilla build with native SVG support and the problem is solved.
Thank you very much.
Mass reassign of SVG bugs that aren't currently being worked on by Alex to
general@svg.bugs. If you think someone should be assigned to your bug you can
join the #svg channel on mozilla.org's IRC server ( irc://irc.mozilla.org/svg )
where you can try to convince one of the SVG hackers to work on it. We aren't
always there, so if you don't get a response straight away please try again later. 
Assignee: alex → general
Marking WORKSFORME given comment 8.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.