Last Comment Bug 253715 - document.selection.createRange().text does not select text within form fields
: document.selection.createRange().text does not select text within form fields
Status: RESOLVED INVALID
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Windows 2000
: -- normal (vote)
: ---
Assigned To: Blake Ross
:
Mentors:
http://www.quirksmode.org/js/selected...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-30 06:58 PDT by Alex Lein
Modified: 2005-01-24 13:04 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Alex Lein 2004-07-30 06:58:44 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

This page is an example of how to return the selected text in javascript.
Firefox does not return selected text if the text is selected inside a
<textarea> or <input> field.

Reproducible: Always
Steps to Reproduce:
1. go to http://www.quirksmode.org/js/selected.html
2. enter some random text into the supplied <textarea>
3. select some or all of the text
4. press the Get Selection button/link

Actual Results:  
the <textarea> was cleared... no selected text was returned

Expected Results:  
the selected text should re-appear in the supplied <textarea>
Comment 2 Alex Lein 2004-07-30 10:30:53 PDT
ok, i see.
perhaps this should be a feature request then.
Comment 3 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2004-07-30 10:41:24 PDT
Don't change it fo fixed.
It is a duplicate, invalid or a wontfix, but it is not fixed.
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2005-01-24 13:04:56 PST
The page has since been updated to use Mozilla-compatible code.

Note You need to log in before you can comment on or make changes to this bug.