If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cannot change product and remove multiple entries from CC list at once

RESOLVED WORKSFORME

Status

()

Bugzilla
Creating/Changing Bugs
RESOLVED WORKSFORME
13 years ago
5 years ago

People

(Reporter: Matt Walsh, Assigned: myk)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: 

If you try to remove 2 or more CC list members and change the product at
the same time, you get an error saying The username "user1user2user2" is not
a valid user name.

Product verification template (globals/hidden-fields.html.tmpl) doesn't
handle lists (only single values).

Reproducible: Always
Steps to Reproduce:
1. Change product.
2. Select 2 or more users in cc list.
3. Click remove cc.
4. Commit. You get the product verification form.
5. Choose the new version, component, etc.
6. Commit verification form.
7. You get the error message about an invalid username.



Expected Results:  
Should have processed the same as if the verification form didn't display.

Workaround. Don't remove cc members and change product at the same time.
I could swear we fixed this a while back.  What version of Bugzilla are you using?
I can't reproduce this either on 2.16.6, 2.18rc2, or cvs tip.  Seems to work fine.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.