Closed Bug 253757 Opened 18 years ago Closed 18 years ago

Sub-menus on context menu don't open automatically

Categories

(Firefox :: Menus, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: bugzilla, Assigned: vlad)

Details

(Keywords: fixed-aviary1.0, regression, Whiteboard: [have patch])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040730 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040730 Firefox/0.9.1+

Several extensions add sub-menus to the context menu.  In previous builds, the
sub-menu would pop open on mouseover.  On 20040730, a left-click is now required
to open the extenson's sub-menu.

Reproducible: Always
Steps to Reproduce:
1. Install an extension that uses a context menu (for example, MakeLink
http://www.netsoc.ucd.ie/~finuvir/makelink_1.2.xpi ) and restart Firefox.
2. Right-click anywhere on the page and mouse over the context menu item "Make
Link >"


Actual Results:  
The context menu did not open, and a left-click was required to open it.

Expected Results:  
The context menu should open automatically on mouseover.

I saw this bug with three of the extensions I use (Make Link, Linky, and
BBCode).  Another user in the forums verified the bug with two other extensions
(ReloadEvery and ImageZoom).  Looking through yesterday's checkins, I thought it
might be associated with either Bug 243720 [bookmark can't move into sub-folder
in personal toolbar (drag and drop)] or Bug 203183 [Bookmarks context menu stays
when clicking other menus].
confirmed for latest FF branch build (Gecko/20040730 Firefox/0.9.1+)
This broke recently. Blake, can you look at this?
Severity: minor → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-aviary1.0PR+
Keywords: regression
It's not just extensions. Firefox has sub-menus on the context menu for frames
and iframes. 
Vlad, could this be your changes at bug 203183

*** This bug has been marked as a duplicate of 203183 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Oops, need more coffee. Meant to reassign, not dupe. 
Assignee: firefox → vladimir
Status: REOPENED → NEW
Uggh, I know why this is happening -- the menu open timer is just checking
whether any popup is open and refusing to open, it's not checking whether it's
about to open a submenu of the popup itself.  Will fix ASAP.
Status: NEW → ASSIGNED
patch; just does the check (also removes unnecessary addref).
Whiteboard: [have patch]
Comment on attachment 154877 [details] [diff] [review]
context-menu-popup-fix-0.patch

a=ben@mozilla.org
Attachment #154877 - Flags: approval-aviary? → approval-aviary+
in, fixed.
Status: ASSIGNED → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → FIXED
Keywords: fixed-aviary1.0
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.