What to do with close tab icon [x] when only one tab is open?

VERIFIED DUPLICATE of bug 248987

Status

()

Firefox
Tabbed Browser
VERIFIED DUPLICATE of bug 248987
14 years ago
14 years ago

People

(Reporter: tracy, Assigned: Fritz Schneider)

Tracking

unspecified
Points:
---
Bug Flags:
blocking-aviary1.0PR -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
With the "Hide tab bar when only one web site is open" pref disabled, the tab
should *always* be present.  The Close Tab item in the tab context menu is
disabled when there is only one tab open.  For consistancy, can we disable or
hide the close tab icon [x] when only one tab is open.
(Reporter)

Updated

14 years ago
Flags: blocking-aviary1.0PR?

Comment 1

14 years ago
shoot for 1.0 on this
Flags: blocking-aviary1.0PR?
Flags: blocking-aviary1.0PR-
Flags: blocking-aviary1.0?

Comment 2

14 years ago
fritz, it would be good to help on this one if you can - thanks
Assignee: bugs → fritz

Comment 3

14 years ago
(In reply to comment #0)
> ... The Close Tab item in the tab context menu is
> disabled when there is only one tab open.  For consistancy, can we disable or
> hide the close tab icon [x] when only one tab is open.

Go for disable (gray-out) rather than hide.
1. It's better a user wonder why the icon is grayed out than completely missing.
2. And, if you're going for consistency, then it would be a good idea to match
the current graying-out of the r-click options on the tab by graying out the "x"
button, too.

Comment 4

14 years ago
See bug 156082 for more thoughts on this issue.
bug 248987 seems like a better solution, much more like most tabbed interfaces
I've used.  We need to pick one or the other.
(Reporter)

Comment 6

14 years ago
Sounds good. I like that you can go back from a blank tab. That solution always
keeps the tab bar visible, as disbaling the hide tab bar pref implies.

Marking this bug a dupe of 248987

*** This bug has been marked as a duplicate of 248987 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Flags: blocking-aviary1.0?
Resolution: --- → DUPLICATE
Summary: Disable or hide close tab icon [x] when only one tab is open → What to do with close tab icon [x] when only one tab is open?

Updated

14 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.