browser.tabs.loadOnNewTab in about:config ineffectual

VERIFIED DUPLICATE of bug 269664

Status

()

defect
VERIFIED DUPLICATE of bug 269664
15 years ago
4 years ago

People

(Reporter: bugzilla16, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

Setting browser.tabs.loadOnNewTab settings in about:config doesn't do anything.
UI for it should be in Tools->Options, like it is in the suite, also.
http://kb.mozillazine.org/index.phtml?title=Firefox_:_FAQs_:_About:config_Entries

Reproducible: Always
Steps to Reproduce:
1. navigate to about:config
2. change the value to 1 (or -1 or 0 or 2)
3. Press CTRL+T (or right-click, "New Tab")
4. Tab opens "blank"

Actual Results:  
New Tabs should display what was set.

Expected Results:  
from:
http://kb.mozillazine.org/index.phtml?title=Firefox_:_FAQs_:_About:config_Entries

browser.tabs.loadOnNewTab - Integer
Set what should be displayed in a newly created tab
-1: Browser Startup Page
0: Blank Page
1: Your Homepage
2: Last Visited
I searched bugzilla and the mozillazine forums, and could find others mentioning
that this doesn't work, but can be fixed with TBE or TBP extensions, but
couldn't find it listed in Bugzilla
ala bug 187573 your desire to have it work is a WONTFIX.  However, looking
through the source (firefox.js), testing a new profile, etc, it seems that
browser.tabs.loadOnNewTab doesn't exist anymore.  Yet it will still show up in
about:config on a fresh profile.

So there is a problem that a pref that doesn't exist anymore is still showing up.

Excluding xpfe/, The only reference on the aviary branch I can find for
'loadOnNewTab' is here:
http://lxr.mozilla.org/aviarybranch/source/toolkit/components/history/src/nsGlobalHistory.cpp#706
ok, so then the bug is really:
"browser.tabs.loadOnNewTab shows up in about:config, when it doesn't do anything
and should therefore be removed from about:config (since its not going to ever
do anything)"


I gather the reason that this is a WONTFIX is part of the "keeping Firefox
minimal" goal.  Its not a feature of Firefox, but similar functionality may be
added (if the user wants) by installing an extension.

If that is the rational, then that's fine with me.  


Though, of course I'd rather that this option stay, since it seems a pretty
fundamental part of tabbed browsing.  But, whatever's fine.
This option is works as it should in the Mozilla Suite... why it doesn't work in
Firefox is extremely annoying and it should be fixed before 1.0 comes out.

It's been broken for a while now.

Fix it or the users will rise up against thee!
(In reply to comment #3)
>  but similar functionality may be added (if the user wants) by installing an
>  extension.

what extension is that?

(In reply to comment #3)
> ok, so then the bug is really:
> "browser.tabs.loadOnNewTab shows up in about:config, when it doesn't do anything
> and should therefore be removed from about:config (since its not going to ever
> do anything)"
So either the summary should be changed to reflect this or this bug should be
resolved as WONTFIX (see bug 237230 comment 3, bug 187573).
see bug 269664 comment 1, bug 269852 and bug 269854.

*** This bug has been marked as a duplicate of 269664 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.