All users were logged out of Bugzilla on October 13th, 2018

crashes on loading page [@ gfxImageFrame::SetAlphaData ]

VERIFIED DUPLICATE of bug 253782

Status

--
critical
VERIFIED DUPLICATE of bug 253782
14 years ago
8 years ago

People

(Reporter: james, Unassigned)

Tracking

({crash, crashreportid})

Trunk
x86
Windows XP
crash, crashreportid

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

when loading this page (I used link to story from main www.hulver.com site)
firefox crashes

Reproducible: Always
Steps to Reproduce:
1. go to http://www.hulver.com/scoop/story/2004/7/23/195343/919
2.
3.

Actual Results:  
firefox displays crash dialog 

Expected Results:  
load the page

Comment 1

14 years ago
This also crashes with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

TB458305E, TB458334E

Comment 2

14 years ago
M1.7/W2K -> TB458420X
20040730/1.8a3/W2K -> TB458424Z

-> Browser
Assignee: firefox → general
Component: General → Browser-General
Keywords: crash, talkbackid
Product: Firefox → Browser
QA Contact: firefox.general → general
Version: unspecified → Trunk

Comment 3

14 years ago
-> GFX

It crashes in gfxImageFrame::SetAlphaData, line 386 because row_stride is zero.

383 #if defined(XP_WIN) || defined(XP_OS2)
384   // Adjust: We need offset to be top-down rows & LTR within each row
385   //    On win32 & os/2, it's passed in as bottom-up rows & LTR within each row
386   PRUint32 yOffset = ((PRUint32)(aOffset / row_stride)) * row_stride;
387   offset = ((mSize.height - 1) * row_stride) - yOffset + (aOffset % row_stride);
388 #else
389   offset = aOffset;
390 #endif

The first similar talkback stack dates from 2004-07-30 14:09:04.0
Status: UNCONFIRMED → NEW
Component: Browser-General → GFX
Ever confirmed: true

Comment 4

14 years ago
In such case it's probably dupe of bug 253782 - marking such.

*** This bug has been marked as a duplicate of 253782 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Summary: crashes on loading page → crashes on loading page [@ gfxImageFrame::SetAlphaData ]
verified dup
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
Crash Signature: [@ gfxImageFrame::SetAlphaData ]
You need to log in before you can comment on or make changes to this bug.