If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

firefox crashes on Windows 95 if it is started without available profile [@ FIREFOX.EXE ]

VERIFIED DUPLICATE of bug 246338

Status

()

Firefox
General
--
critical
VERIFIED DUPLICATE of bug 246338
13 years ago
13 years ago

People

(Reporter: Norbert, Assigned: Blake Ross)

Tracking

({crash})

Trunk
x86
Windows 95
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.8a3) Gecko/20040731 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.8a3) Gecko/20040731 Firefox/0.9.1+

Firefox crashes if starting without profile:


The (german) error output of winsows:

FIREFOX verursachte einen Fehler durch eine ung├╝ltige Seite
in Modul FIREFOX.EXE bei 0137:00853491.
Register:
EAX=00000000 CS=0137 EIP=00853491 EFLGS=00010297
EBX=00000000 SS=013f ESP=00c7f750 EBP=00c7f77c
ECX=00000001 DS=013f ESI=602fd8c3 FS=256f
EDX=00c7f764 ES=013f EDI=00e95d80 GS=0000
Bytes bei CS:EIP:
8b 08 ff 51 0c 8b 1d 2c 7f 88 00 8d 4d e8 ff d3 
Stapelwerte:
00000000 00c7f764 00e95d9c 00e95d98 602c4e54 60303548 00a160d4 00000007 00000001
00dc5a64 00000000 00c7f7a0 00853407 602fd8c3 00000000 602fd95b 


But after the crash, a profile is generated. So the next time Firefox starts
without crashing.

I don't really know if this bug depends on bug 249593. But bevore the builds
with the there described problems, I could not reproduce this bug, as I
remember. Than came the builds with the bug 249593 that did in general not work
with Windows 95. The current nightlies run again under Windows 95, but with the
here described problem, if not profile is available.

Reproducible: Always
Steps to Reproduce:
(Reporter)

Comment 1

13 years ago
typing errors:

"winsows" -> "windows"
"not profile" -> "no profile"

Comment 2

13 years ago
Norbert: Could you provide TalkBack incident ID?
Keywords: crash
Whiteboard: DUPEME
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> Norbert: Could you provide TalkBack incident ID?

Sorry, I don't know what "TalkBack incident ID" is. :-)
(Reporter)

Updated

13 years ago
Summary: firefox crashes if it is started without available profile → firefox crashes on Windows 95 if it is started without available profile
(Reporter)

Comment 4

13 years ago
(In reply to comment #0)

Sorry, more typing errors:

"Than came the builds..." -> "Then came the builds..."

Comment 5

13 years ago
Mozilla releases nightly and milestone builds with Talkback, which should catch
most crashes and offer to send in a crash report. Developers can retrieve that
crash report and attach it to your bug report if you provide either the Incident
ID (you can get it by running the TalkBack program from /components/talkback/).
Thanks for your help in testing Mozilla and reporting bugs.
QA Contact: firefox.general → owen-bugzilla
(Reporter)

Comment 6

13 years ago
(In reply to comment #5)

OK. I will try to do this. But I can't before next week end, sorry.
(Reporter)

Comment 7

13 years ago
Could you please tell me, where I can get talkback.exe from? I cannot find it in
my Firefox-folder of the nightly build I use.
(Reporter)

Comment 8

13 years ago
Sorry. Latest-trunk nightlies are the only builds that currently run on Windows
95. But they do not include talkback.exe.

All other builds do not run on Windows 95 due to bug 249593.
(Reporter)

Comment 9

13 years ago
Could please someone give me a trunk-build with talkback.exe !?!?!?!?!?!?
(Reporter)

Comment 10

13 years ago
[I set Version to "Trunk". I hope this is correct so.]
Version: unspecified → Trunk

*** This bug has been marked as a duplicate of 246338 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
(Reporter)

Comment 12

13 years ago
Now recent latest-trunk nightlies have Talkback!

Incident ID: TB699431K

Updated

13 years ago
Keywords: talkbackid

Comment 13

13 years ago
TB699431K looks useless:
FIREFOX.EXE + 0x455e5a (0x00855e5a)
FIREFOX.EXE + 0x455cf8 (0x00855cf8)
XPCOM.DLL + 0x361ba (0x602f61ba)
FIREFOX.EXE + 0x1cc3d (0x0041cc3d)
FIREFOX.EXE + 0x1ab84 (0x0041ab84)
JS3250.DLL + 0x1c20b (0x6008c20b)
JS3250.DLL + 0x1c4f8 (0x6008c4f8)
JS3250.DLL + 0x1c5f4 (0x6008c5f4)
JS3250.DLL + 0x2a1eb (0x6009a1eb)
JS3250.DLL + 0x21139 (0x60091139)
JS3250.DLL + 0x1c24b (0x6008c24b)
JS3250.DLL + 0x19ad5 (0x60089ad5)
JS3250.DLL + 0x1c20b (0x6008c20b)
JS3250.DLL + 0x21977 (0x60091977)
JS3250.DLL + 0x1c24b (0x6008c24b)
JS3250.DLL + 0x1c4f8 (0x6008c4f8)
JS3250.DLL + 0x1c5f4 (0x6008c5f4)
JS3250.DLL + 0x2a4b5 (0x6009a4b5)
JS3250.DLL + 0x1dc7f (0x6008dc7f)
JS3250.DLL + 0x1c24b (0x6008c24b)
JS3250.DLL + 0x21977 (0x60091977)
JS3250.DLL + 0x1c24b (0x6008c24b)
JS3250.DLL + 0x1c4f8 (0x6008c4f8)
JS3250.DLL + 0x4c0a (0x60074c0a)
FIREFOX.EXE + 0x12c9a1 (0x0052c9a1)
FIREFOX.EXE + 0x289edd (0x00689edd)
FIREFOX.EXE + 0x2cc7cb (0x006cc7cb)
FIREFOX.EXE + 0x2cc8fa (0x006cc8fa)
FIREFOX.EXE + 0x2802fd (0x006802fd)
FIREFOX.EXE + 0x1be8e3 (0x005be8e3)
FIREFOX.EXE + 0x16b4a5 (0x0056b4a5)
FIREFOX.EXE + 0x17cd8b (0x0057cd8b)
FIREFOX.EXE + 0x1c5a50 (0x005c5a50)
FIREFOX.EXE + 0x1c6b02 (0x005c6b02)
FIREFOX.EXE + 0x1c708d (0x005c708d)
FIREFOX.EXE + 0x4d0ad (0x0044d0ad)
FIREFOX.EXE + 0x85167 (0x00485167)
Keywords: talkbackid
Summary: firefox crashes on Windows 95 if it is started without available profile → firefox crashes on Windows 95 if it is started without available profile [@ FIREFOX.EXE ]
Status: RESOLVED → VERIFIED
Crash Signature: [@ FIREFOX.EXE ]
You need to log in before you can comment on or make changes to this bug.