Link doesn't open local page properly

RESOLVED WORKSFORME

Status

()

Core
Networking
--
major
RESOLVED WORKSFORME
14 years ago
5 years ago

People

(Reporter: Matti, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040729
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040729

<a
href="file:///D:\thecia\reviews\=redirect.html">file:///D:\thecia\reviews\=redirect.html</a>

Clicking on this link (generated by Xenu) opens the file =redirect.html but the
address shows as "file:///D:%5Cthecia%5Creviews%5C=redirect.html". The page has
the text and HTML but none of the CSS. If i edit it in Composer, it appears the
same way. If I try to save it, the save dialog shows
"D-%5Cthecia%5Creviews%5C=redirect.html", albeit in the right folder.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Assignee: general → darin
Component: Browser-General → Networking
QA Contact: general → benc
The "\" character gets escaped and converted to %5C.  If you use "/" instead,
e.g. file:///D:/cvs-1.11.5/mozilla/mozbuild.log - it won't be changed.  Then, if
you save the page, it just saves as "mozbuild.log".  It's possible that the
save-as dialog should recognize %5C as a directory separator, but the current
behavior might be by design.

Are you sure your css file is referred to properly?  A test page I created
worked properly.

Comment 3

14 years ago
-> NEW.

I guess we had to give up on this issue, it was just a matter of time....
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

14 years ago
This bug happens when there are backslashes in the local path.  When I changed
the path to forward slashes it worked.  For example:

This works: 

file:///c:/usr/html/info.html
links find to
info2.html ( in the /usr/html directory)

Whereas 
file:///c:%5Cusr%5Chtml%5Cinfo.html
comes up with this
file:///info2.html

for this page
info2.html ( in the /usr/html directory)

HTML is: <a href="info2.html> Info 2 </a>

Comment 5

14 years ago
This bug happens when there are backslashes in the local path.  When I changed
the path to forward slashes it worked.  For example:

This works: 

file:///c:/usr/html/info.html
links find to
info2.html ( in the /usr/html directory)

Whereas 
file:///c:%5Cusr%5Chtml%5Cinfo.html
comes up with this
file:///info2.html

for this page
info2.html ( in the /usr/html directory)

HTML is: <a href="info2.html> Info 2 </a>

Found this in FireFox 1.0
Doug: yes, that's exactly what comment 0 said... I'm not sure why you repeated
it (twice!)

also, there is no firefox 1.0, only a preview release.

Updated

12 years ago
Assignee: darin → nobody
QA Contact: benc → networking

Comment 7

12 years ago
Environment: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

All text and images view fine for these:
file:///c:/usr/html/info.html
file:///c:\usr\html\info.html

This almost works properly:
file:///c:%5Cusr%5Chtml%5Cinfo.html

All the text appears properly, but kansas IMG SRC does not display, html is:
<A HREF="http://ecs.csus.edu/~laned/index.html"><IMG SRC="pics/kansas.gif" ALT="Doug's Home Page">return to Doug's home page</A>
The ALT text displays instead.

So somewhow the %5C messes with the internal path which is used to load
certain images.

The comment #5 was an attempted correction, clicked too fast.  I referred to info2.html instead of info.html.
Works for me. Latest Nightly is opening any html/htm file wherever they may be saved.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.