Doubleclicking isn't button-specific, should be

RESOLVED DUPLICATE of bug 244692

Status

()

Toolkit
Add-ons Manager
--
trivial
RESOLVED DUPLICATE of bug 244692
14 years ago
10 years ago

People

(Reporter: Jesper Hermansen, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

When doubleclicking on an installed extension for options, you can doubleclick
with both the left, right and middle-mousebutton.
Also you can make combinations of these, like "left-right" click, "middle-right"
click, "left-middle" click.
The only combinations you can't do, is when starting with the right-mousebutton,
except when the second button-click is also a right-click. So "right-right"
click will show the option-dialog for the selected extension, but "right-left"
and "right-middle" click will not!

This bug is also in Tools->Options...->Downloads->File types if you doubleclick
on any of the items. Except that you can also use the "right-left" and
"right-middle" click combinations.

Reproducible: Always
Steps to Reproduce:
1. Select Tools->Extensions.
2. Try any doubleclick-combination as described above.

For Downloads->File types:
1. Select Tools->Options...->Downloads
2. In the "File types" area, try any doubleclick combination as described above.
Actual Results:  
The items option-dialog is opened.

Expected Results:  
If you doubleclicked with your left mousebutton only, the items options-dialog
should open, else nothing should happen.

Comment 1

14 years ago
Only file bugs with nightly builds please, this has been fixed.

You can get nightly branch builds here:
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-0.9/

*** This bug has been marked as a duplicate of 244692 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.