Chinese characters not displayed

VERIFIED DUPLICATE of bug 233689

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 233689
14 years ago
14 years ago

People

(Reporter: me, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

Chinese characters are not displayed at all, just little squares with numbers in
them [wrong font?]. This is in displaying a page with HTML entities &Wx...; in
it.  Mozilla displays them correctly. Setting view options does not help. May be
documentation problem. 

Reproducible: Always
Steps to Reproduce:
1. display http://en.wikipedia.org/wiki/Main_Page
2. look at other languages on left hand side, locate references to Chinese and
Japanses
3.

Actual Results:  
little square boxes

Expected Results:  
Chinese characters for zhongwen and hihongo
(Reporter)

Comment 1

14 years ago
Or try http://people.linux.net.cn/holywen/ which comes up as entirely unreadable
(should be lots of Chinese characters).

The problem might be that I am doing 'something wrong', but in that case it
should at least be documented as to what the 'right thing' is. If Firefox is to
be mass-consumer product then it should do the right thing out of the box.
(Reporter)

Comment 2

14 years ago
Seems to be the same problem.

*** This bug has been marked as a duplicate of 233689 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.