In download dialog sizes and transfer rate are negative and size incorrect on >2Gb files

VERIFIED DUPLICATE of bug 228968

Status

()

Toolkit
Downloads API
VERIFIED DUPLICATE of bug 228968
14 years ago
10 years ago

People

(Reporter: paul bilke, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Opera/7.52 (Windows NT 5.1; U)  [en]
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

When downloading large file > 2GB when past 2G the size rolls over (signed) and 
the transfer rate is also negative.  The "OF" parameter is also wrong saying 73.
9Mb when the file is actually 4.1Gb

Reproducible: Always
Steps to Reproduce:
1. select download link for very large file (URL above as example)
2. Select save to disk
3. Size is wrong when beginning and after you get to 2^30 bytes transfered and 
rate become negative

Actual Results:  
Negative ratte and transfered bytes

Expected Results:  
Size should continue counting upward instead of rolling over

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 228968 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.