Closed Bug 253959 Opened 15 years ago Closed 15 years ago

Mozilla spawns multiple windows (invalid img src)

Categories

(Firefox :: General, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 181860

People

(Reporter: overlordq, Assigned: bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

This page contains many incorrect <img src> tags which causes Mozilla to spawn a
multitude of (Insert Mail Program Here) Windows, in additon to telnet, et al.

Reproducible: Always
Steps to Reproduce:
1. Load Site


Actual Results:  
Millions of windows open

Expected Results:  
Mozilla detects that the <img src="mailto:omg"> is an invalid image url.
Summary: Mozilla spawns multiple windows → Mozilla spawns multiple windows (invalid img src)

*** This bug has been marked as a duplicate of 181860 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b) Gecko/20050205
Firefox/1.0+

As implied elsewhere, this testcase is next to impossible to use, even for
testing, because it has a meta element

<meta http-equiv="Refresh" content="0">

This means that cancel does not mean cancel becase you will be asked an
infinite number of times.

There is a proposal (which I support wholeheartedly) to put Refresh
into the same sort of jail as pop-ups, that is, not do it.

Bug 256982 "Disable automatic page refresh / reload"
Bug 280907 "Request ability to prevent web sites from reloading repeatedly"

See Bug 83265 "Add a way to disable HTTP-EQUIV=refresh (block automatic meta 
redirection, lock on current page)" Especially Bug 83265 Comment 22 .

In the meantime can we never execute  content="0"? My proposal would be 

    content="0"  => Never refreshed
    "0" > content > "5" => content replaced with 5

Bug 159866 "Horrific Crash on malicious redirect to malformed URL (c:\nul\nul)"
Bug 159866 Comment 5 makes the same request.

The rationale behind this is obvious: The User not the author should be
in charge of the browser.

Incredibly, since content="0" is so obviously wrong
http://www.susqu.edu/webcentral/htmltag/tag3.cfm , it is widely 
recommended to beginning web authors as a quick and dirty
way of doing a 'redirect'.

See Bug 170021 "URL reloads continuously due to invalid meta refresh"
which discusses the same fix that I am proposing - ignore unacceptable
Refresh requests. 

(An alternative to my suggestion would be to actually rewrite
a content-"0' Refresh as a 301 moved permanently (the author
wants a permanent loop ...) and "... any future references to this 
resource SHOULD use one of the returned URIs. Clients with link 
editing capabilities ought to automatically re-link references 
to the Request-URI to one or more of the new references returned 
by the server, where possible ..." and never render a page
with a refresh of "0", and not render a self-refreshing page
with content="0" at all).

This would also fix  Bug 77359 "Page with meta refresh set to 0 don't 
execute body onload tag", by making it clear that nothing would get 
loaded or executed if the is a pending Refresh with content="0"
You need to log in before you can comment on or make changes to this bug.