If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Downoad Error - Firefox gives error message if a file w/ the same name is downloaded to the same directory

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: firefoxbug, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

I'm downloading an updated version of a file to the current directory that it is
in.  I get the following error message when I try to do this.  <i>Filename</i>
could not be saved, because you cannot change the contents of that folder. 
Change the folder properties and try again, or try saving in a different location.

Reproducible: Sometimes
Steps to Reproduce:
1. I download a *.exe file from a website to a specified directory
2. When an updated copy of that file is posted to the website, I download it
again to the same directory.
3. Sometimes I get the error message that I listed in the details above,
sometimes I don't.  The folder permissions list "Everybody" as having Full
Control for that folder.

Actual Results:  
I get the error message: "<i>Filename</i> could not be saved, because you cannot
change the contents of that folder.  Change the folder properties and try again,
or try saving in a different location."  Also, Firefox has removed the original
file and not downloaded the new file.

Expected Results:  
Firefox should download the new copy of the program and overwrite the older
version.  If it can't do this, then it shouldn't delete the older version.
it can't do that if the file is in use (or locked).

WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.