No caret in find toolbar when opening over fast find ('/')

VERIFIED FIXED in mozilla1.8rc1

Status

()

Toolkit
Find Toolbar
VERIFIED FIXED
14 years ago
9 years ago

People

(Reporter: whimboo, Assigned: masayuki)

Tracking

unspecified
mozilla1.8rc1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040728
Firefox/0.9.1+

The find toolbar misses a caret. So you aren't able to use the left and right
keys to correct some typo. Recognizing a typo at the beginning of a long word
results in deleting the whole letters which follows. It would be nice when we
could position the caret directly to the typo for changings.
(Reporter)

Comment 1

14 years ago
This bug does not appear when the find toolbar is opened with the shortcut
Ctrl+F. In such a situation the caret is available. Instead opening the toolbar
with '//' results in none caret.
Summary: Can't scroll through search string cause caret is not available → No caret in find toolbar when opening over fast find ('//')
(Reporter)

Updated

14 years ago
Summary: No caret in find toolbar when opening over fast find ('//') → No caret in find toolbar when opening over fast find ('/')

Comment 2

14 years ago
It is intentional that "/" puts focus on the found item rather than the Find
bar.  This allows you to follow links by pressing Enter.

Comment 3

13 years ago
However the current "/"(text mode) or "'"(links mode) FAYT feature doesn't allow
to input non-western characters in an asian user experience unless focusing the
caret onto the Find Toolbar by mouse.
I doubt it's due to the lack of caret.
It does work very well in Mozilla, but not in Firefox Find Toolbar.

Comment 4

13 years ago
What Jesse said--this is not a bug.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
> What Jesse said--this is not a bug.

That was a bug and is fixed now in current trunk builds like Mozilla/5.0 (X11;
U; Linux i686; en-US; rv:1.9a1) Gecko/20050918 Firefox/1.6a1
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Reporter)

Updated

12 years ago
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

12 years ago
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
This is fixed by bug 259454.
Assignee: firefox → masayuki
Status: REOPENED → NEW
Depends on: 259454
OS: Windows 2000 → All
Hardware: PC → All
Target Milestone: --- → Firefox1.5rc1
-> FIXED
Status: NEW → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
(Reporter)

Updated

12 years ago
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.