Pressing slash when find toolbar is visible but not focused replaces find box contents with slash ('/')

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: 32768, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040725 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040725 Firefox/0.9.1+

At times the find toolbar can lose keyboard focus but still be visible. 
However, when this happens it causes annoying behaviour with the slash key.

Further typing will not add any text to the find toolbar, of course, because it
is not focused.  So, in order to get the find toolbar focus again, you need to
press slash (/).  However, pressing slash not only focuses the find toolbar
ready for a new search, it also adds a slash to the "Find" field of the find
toolbar.

Reproducible: Always
Steps to Reproduce:
1. Press slash and use find as you type to find a word that exists on the page
2. Wait until the find toolbar times out and disappears
3. Press F3 to repeat the previous search
4. Switch to another tab or click somewhere in the page, to remove focus from
the find toolbar.
5. Press the slash key ('/') to type into the find toolbar again.
Actual Results:  
Toolbar gains keyboard focus, text in toolbar is cleared and a slash is inserted
into the box.

Expected Results:  
Toolbar gains keyboard focus, text in toolbar is cleared.

Another possible way of treating this bug would be to call it:
"Find toolbar sometimes remains visible after losing keyboard focus".  That is,
another way of fixing it would be to ensure that the find toolbar disappears
whenever it loses focus.
(Reporter)

Comment 1

14 years ago
(Sorry for mistake)

Step 4 above, 
"4. Switch to another tab or click somewhere in the page"
should read:
"4. Press tab or click somewhere in the page"

Comment 2

14 years ago
I can reproduce this with the latest branch builds on Windows XP. Slash should
simply focus the find textbox and not also enter the "/" character
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-aviary1.0+

Comment 3

14 years ago
The patch to fix this bug is included in the patch to fix bug 251073
(Reporter)

Comment 4

14 years ago
This seems to be fixed now.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

14 years ago
Flags: blocking-aviary1.0+

Comment 5

14 years ago
This bug should not be resolved, it still exists on Firefox 1.0, 1.x.

This bug is fixed with the patch in bug 265915
(Reporter)

Comment 6

14 years ago
(In reply to comment #5)
> This bug should not be resolved, it still exists on Firefox 1.0, 1.x.

I cannot reproduce this bug in Firefox 1.0.  It is resolved WORKSFORME in the
sense that following the 'steps to reproduce' no longer cause the bug described.

Can you describe how you managed to observe this bug in Firefox 1.0?  If you
observed the described behaviour but under different circumstances, should that
not belong in a separate bug report?
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.