[Mac 0.9.3] fails to start (corrupted XUL cache)

RESOLVED DUPLICATE of bug 206058

Status

()

--
critical
RESOLVED DUPLICATE of bug 206058
14 years ago
7 years ago

People

(Reporter: bugzilla, Assigned: bugzilla)

Tracking

1.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
found using 2004080211-0.9.3. however, let me know if there were other known
issues which broke this build.

1. download the disk image and decompress it.
2. installed in unique folder (one I created on desktop).
3. dbl-click firefox icon.

expected: firefox should launch and load home page, display menubar, etc.

actual results:

* browser window appears with the following (unfortunately, clipped) error at
the bottom:

  oncommand="MultiplexHandler(event)" onpopupshowing="CreateMenu('browser');U

* the menubar has only two items: the Apple menu and a shortened Firefox menu
(showing only basic window commands, services and quit).
(Reporter)

Comment 1

14 years ago
tracy/marcia, can either of you repro this?

also, kinda curious if a similar issue will occur with linux/win 0.9.3 bits,
once they come out...

Comment 2

14 years ago
WFM with the same build.
Sarah: I am unable to reproduce this on the G5 Mac in the office.
(Reporter)

Comment 4

14 years ago
tested this on a dual-cpu G4 running 10.3.4. will re-download and try again.
(Reporter)

Comment 5

14 years ago
hunh, I re-downloaded and to be safe, started with a new profile, and this is no
longer a problem.
(Reporter)

Comment 6

14 years ago
also works fine with a profiles created with 0.9 or 0.8. wonder if this was
brought one by using the profile with nightly (not release) builds.

lowering severity and removing smoketest kw as this works fine with using
release builds -> 0.9.3.
Severity: blocker → critical
Keywords: smoketest
(Reporter)

Comment 7

14 years ago
with my non-working profile, I tried the following:

a. threw away the Extensions folder, restart Firefox-0.9.3. results: still
encountered error.

b. threw away XUL.mfasl, restart Firefox-0.9.3. results: no error!

looks like XUL cache corruption...
Summary: [Mac 0.9.3] fails to start → [Mac 0.9.3] fails to start (corrupted XUL cache)
sairuh, if you think this bug can be resolved simply write it down and we'll
close that one
(Reporter)

Comment 9

14 years ago
at first I didn't find an open bug in Firefox for corrupted xul cache, but then
I found bug 206058 for seamonkey. I didn't rename files to get into this bad
state (not sure what the steps would be, other than my habit of using
nightlies), but if you think it's close enough, feel free to dup this one
against bug 206058.
duped

*** This bug has been marked as a duplicate of 206058 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.