Using "Mark All As Read" makes Quick Search bar unusable

RESOLVED DUPLICATE of bug 199019

Status

SeaMonkey
MailNews: Message Display
--
major
RESOLVED DUPLICATE of bug 199019
14 years ago
13 years ago

People

(Reporter: Nevin Cheung, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a2) Gecko/20040714
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a2) Gecko/20040714

Related to bugs 194147 (which seems to have been resolved) and 253432/250005, if
you select Message->Mark->Mark All As Read in the menu (the only way to do it
now, since Shift-Command-C/M doesn't work now...), "c" cannot be used as a
character in the Quick Search Bar -- a "Mark as Read by Date" popup happens.
Only way to fix is to exit and restart.

Reproducible: Always
Steps to Reproduce:
1. Select Message->Mark->Mark As All Read
2. Go to Quick Search bar, type in a "c" anywhere in the string.

Actual Results:  
Mark as Read by Date dialog box shows up.

Expected Results:  
It should have let me type in the letter "c" in the search.

Comment 1

14 years ago
this works on windows with thunderbird - have not tried mozilla on the mac.
(Reporter)

Comment 2

13 years ago
Even after Mark All as Read was moved back to Command-Shift-C in 1.8a3, the same
behavior exists -- the "C" key is unusable in the Quick Search bar in Mail after
Mark All as Read is triggered, either by menu or by Cmd-Shift-C. Must restart
Mozilla to clear the state.

Comment 3

13 years ago
It reproduced.

Mac OS X 10.3.5
Thunderbird version 0.7+ (20040821)

Comment 4

13 years ago
Reported behavior is very similar to bug 194147, also reported for Mac OS X.
Product: Browser → Seamonkey

Comment 5

13 years ago

*** This bug has been marked as a duplicate of 199019 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.