If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Page info -> Forms -> Form name is editable

RESOLVED FIXED

Status

SeaMonkey
Page Info
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Edwin Groothuis, Assigned: db48x)

Tracking

({fixed-aviary1.0})

Trunk
x86
FreeBSD
fixed-aviary1.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.7.1) Gecko/20040720
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.7.1) Gecko/20040720

A page with a form is loaded. Go to the Page Info (control-I), select the Forms.

If you select the name of the form in the overview at the top, then the form
details are expanded in the lower part of the dialogbox.
Select the name of the form in the lower part of the dialog (above encoding and
target). Then you can edit it as if it was an input box.

Reproducible: Always
Steps to Reproduce:
1. load page with form
2. go to page info -> forms
3. select a form, select the form name  (Unnamed Form most likely)
4. enter some random keys on the keyboard

Actual Results:  
It changed the text in form name.

Expected Results:  
It should have ignored the changes.
(Assignee)

Comment 1

13 years ago
that's the funniest thing I've every seen. It actually is a textbox, but with
some css so that it looks like a plain label. It's just not marked as being
read-only. Simple enough to fix.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 2

13 years ago
Created attachment 155060 [details] [diff] [review]
fix

Updated

13 years ago
Attachment #155060 - Flags: review+
(Assignee)

Updated

13 years ago
Attachment #155060 - Flags: superreview?(neil.parkwaycc.co.uk)
Comment on attachment 155060 [details] [diff] [review]
fix

rs=me.

/be
Attachment #155060 - Flags: superreview?(neil.parkwaycc.co.uk) → superreview+
(Assignee)

Comment 4

13 years ago
Created attachment 155062 [details] [diff] [review]
fix

fixes firefox as well
Attachment #155060 - Attachment is obsolete: true
(Assignee)

Updated

13 years ago
Attachment #155062 - Flags: approval-aviary?
(Assignee)

Comment 5

13 years ago
went ahead and checked it into the trunk, still waiting on approval for the
aviary branch
(Assignee)

Comment 6

13 years ago
fixed on trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 7

13 years ago
Comment on attachment 155062 [details] [diff] [review]
fix

please don't request approval until you have a fully reviewed patch. thanks.
Attachment #155062 - Flags: approval-aviary?
(Assignee)

Comment 8

13 years ago
Comment on attachment 155062 [details] [diff] [review]
fix

I do have r= and sr=, they're merely on the previous patch
Attachment #155062 - Flags: approval-aviary?

Comment 9

13 years ago
Comment on attachment 155062 [details] [diff] [review]
fix

a=asa for aviary checkin.
Attachment #155062 - Flags: approval-aviary? → approval-aviary+
(Assignee)

Comment 10

13 years ago
fix checked in on aviary branch. Thanks Asa.

Comment 11

13 years ago
This bug seems to have an aviary branch checkin associated with it. If this has
landed on the aviary branch (as much as it's going to for 1.0) can you please
add the "fixed-aviary1.0" keyword? Thanks.

Updated

13 years ago
Keywords: fixed-aviary1.0
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.