ISP RDF functionality broken

RESOLVED FIXED in Thunderbird0.8

Status

--
major
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: jackw, Assigned: mscott)

Tracking

unspecified
Thunderbird0.8
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040802 Firefox/0.9.1+
Build Identifier: 

It seems that in the last two weeks or so, the functionality behind the
defaults/isp rdf entries has been broken.  RDF entries that have worked for a
number of versions are now failing to show any additional screens after
selecting them, and then create a blank account with no options.  I am using a
custom RDF file for our purposes, but the same problem rings true with the
aol.rdf file provided.

Reproducible: Always
Steps to Reproduce:
1. Toss aol.rdf into your defaults/isp folder alongside rss.rdf
2. add a new account
3. select AOL account
4. Hit next

Actual Results:  
The wizard will immediately exit and create a blank AOL account which neither
has the expected settings in it, nor does it even have the account preference
subcategories with which one could edit the preferences after adding.

Expected Results:  
The wizard should go through another screen where it requests realname and
username, and then create a fully-functional aol imap account.

I am using a custom RDF file for our purposes, but the same problem rings true
with the aol.rdf file provided.
(Assignee)

Comment 1

15 years ago
I'm sure my account manager changes for RSS broke this.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → Thunderbird0.8
(Assignee)

Comment 2

15 years ago
Created attachment 155101 [details] [diff] [review]
the fix
(Assignee)

Comment 3

15 years ago
fixed branch and trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

15 years ago
jackw, can you verify that this is now fixed for you? Thanks!
(Reporter)

Comment 5

15 years ago
well, kinda...

As of what I just built (which included patches from some of the other bugs I've
filed), I ran through the wizard just fine, but then at first thunderbird
reflected the new account in the properties window as a newsserver, asking if
you only want to download headers and whatnot, with all fields across the entire
account asbolutely blank.  It still failed to create the default folders and
such as per bug 254290, so I just restarted thunderbird, and it then reflected
it as an imap account again, but with still no ability to actually check any mail.

I think I have the patch from bug 254290 merged in, but I'll rebuild again from
clean after I check it and update on both bugs with what I find out.  Thanks for
all your help.
(Reporter)

Comment 6

15 years ago
nope, that was the case after a full rebuild, it set it up as a news server with
blank defaults as described before... maybe this is a combination of problems
with interrelated bugs?  At any rate, here is the rdf file I'm using:

http://etctest2.bowdoin.edu:9780/~mozilla/bowdoin.rdf

I've also tested with the AOL rdf with similar results, but this is the one I go
to test first, just so that I can disclose as much as possible...
You need to log in before you can comment on or make changes to this bug.