not able do download offline version of the ldap adressbook [@ SINGSIGN_PromptUsernameAndPassword() ]

RESOLVED FIXED in Thunderbird0.8

Status

Thunderbird
Address Book
--
critical
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Patrick Steiner, Assigned: Scott MacGregor)

Tracking

({crash})

unspecified
Thunderbird0.8
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: version 0.7+ (20040802)

if i try do download the ldap adress book tb crashes with the following output:

./run-mozilla.sh: line 451: 19637 Segmentation fault      "$prog" ${1+"$@"}

ah normal addressbook search works fine.


Reproducible: Always
Steps to Reproduce:
1. goto options-> composition
2. edit directories...
3. select an addressbook choose edit
4. goto offline
5. say download now

Actual Results:  
tb crashes

Expected Results:  
download the ldap addressbook

Comment 1

13 years ago
Patrick: Could you provide TalkBack incident ID?
Keywords: crash
(Reporter)

Comment 2

13 years ago
the id is:

TB4702554

Comment 3

13 years ago
Michiel, should this be dupe of bug 252833 - HTTP Auth website makes wallet crash?

TB470255:
SINGSIGN_PromptUsernameAndPassword()
nsSingleSignOnPrompt::PromptUsernameAndPassword()
nsAbLDAPProcessChangeLogData::GetAuthData()
nsAbLDAPProcessChangeLogData::OnLDAPBind()
nsAbLDAPProcessReplicationData::OnLDAPMessage()
XPTC_InvokeByIndex()
EventHandler()
PL_HandleEvent()
PL_ProcessPendingEvents()
nsEventQueueImpl::ProcessPendingEvents()
event_processor_callback()
libglib-2.0.so.0 + 0x4921f (0x00a3d21f)
libglib-2.0.so.0 + 0x23e4a (0x00a17e4a)
libglib-2.0.so.0 + 0x24f28 (0x00a18f28)
libglib-2.0.so.0 + 0x25260 (0x00a19260)
libglib-2.0.so.0 + 0x254cd (0x00a194cd)
nsAppShell::DispatchNativeEvent()
nsXULWindow::ShowModal()
nsContentTreeOwner::ShowAsModal()
nsWindowWatcher::OpenWindowJS()
GlobalWindowImpl::OpenInternal()
GlobalWindowImpl::OpenDialog()
XPTC_InvokeByIndex()
XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode)()
XPC_WN_CallMethod()
js_Invoke()
...
Summary: not able do download offline version of the ldap adressbook → not able do download offline version of the ldap adressbook [@ SINGSIGN_PromptUsernameAndPassword() ]

Comment 4

13 years ago
Just to add that I'm getting exactly the same errors whilst trying to download
an LDAP address book from a Windows 2000 AD server. I'm using the latest nightly
build on Linux. Talkback ID TB534909X.

Comment 5

13 years ago
Marking NEW regarding TalkBack report.

http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=534909
has same stack as in comment #3
Status: UNCONFIRMED → NEW
Ever confirmed: true
Looks very much like a dup. The patch should be ported to aviary.
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Thunderbird0.8
(Assignee)

Comment 7

13 years ago
I ported the fix for bug 252833 to aviary per mvl.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Crash Signature: [@ SINGSIGN_PromptUsernameAndPassword() ]
You need to log in before you can comment on or make changes to this bug.