If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Multi line/wrapped links in messages are interpreted as link + text, and thus points to partially link

RESOLVED INVALID

Status

SeaMonkey
MailNews: Message Display
--
minor
RESOLVED INVALID
13 years ago
12 years ago

People

(Reporter: henning petersen, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040421
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040421

For example will
http://www.atmel.com/dyn/products/tools_card.asp?family_id=627&family_name=FPSLIC&tool_id=2751

appear as
http://www.atmel.com/dyn/products/tools_card.asp?family_id=627&family_name=F
PSLIC&tool_id=2751

This is probably Outlook breaking the line wrongly, but people will blaim
Mozilla anyway.

Reproducible: Always
Steps to Reproduce:
1. Send a link with many characters from MS Outlook and read message in Mozilla
mail. (sorry, don't know the program, can't tell exactly howto)
2. View in Mozilla Mail
3. Clicking won't work because the browser will search for 
http://www.atmel.com/dyn/products/tools_card.asp?family_id=627&family_name=F
instead of 
http://www.atmel.com/dyn/products/tools_card.asp?family_id=627&family_name=FPSLIC&tool_id=2751
Actual Results:  
The site probably won't find the exact page

Expected Results:  
Mozilla should concatenate the broken link and go to the exact page

Comment 1

13 years ago
(In reply to comment #0)
> This is probably Outlook breaking the line wrongly, but people will blaim
> Mozilla anyway.

They can blame away, but if the line break is actually contained within the 
message, there is little Mozilla can do.  URL recognition in a plain text 
message is a heuristic, and there is no solution that will work reliably to 
recognize line-broken URLs while also recognizing URLs that end on one line and 
are followed by ordinary text on the next line.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

13 years ago
- but how does Outlook do it then? Is it some <CR><LF> versus <LF>-only thing?
Product: Browser → Seamonkey

Comment 3

12 years ago
I've recently discovered bug 5351 has been open (a very long time) about this 
same issue; I should have duped this bug to that one.
You need to log in before you can comment on or make changes to this bug.