Dozens of javascript strict warnings during start of Firefox in nsExtensionManager.js

VERIFIED DUPLICATE of bug 249012

Status

()

Toolkit
Add-ons Manager
VERIFIED DUPLICATE of bug 249012
14 years ago
10 years ago

People

(Reporter: whimboo, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040802
Firefox/0.9.1+

During the start of FF the javascript console is filled with dozends of warnings
about nsExtensionManager.js. This happens since the new extension manager was
included. 

For example:

Warning: useless expression
Source File: file:///C:/Programme/Firefox/components/nsExtensionManager.js
Line: 285

Warning: useless expression
Source File: file:///C:/Programme/Firefox/components/nsExtensionManager.js
Line: 288

Warning: redeclaration of var i
Source File: file:///C:/Programme/Firefox/components/nsExtensionManager.js
Line: 669, Column: 13
Source Code:
    for (var i = 0; i < lines.length; ++i)

and so on...
Have you been overwriting your Firefox directories, I bet you did.
Uininstall Firefox
Delete the Firefox directory, NOT your profile
Reinstall Firefox

->WFM

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803
Firefox/0.9.1+
Have you been overwriting your Firefox directories, I bet you did.
Uininstall Firefox
Delete the Firefox directory, NOT your profile
Reinstall Firefox

->WFM

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803
Firefox/0.9.1+
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

14 years ago
Peter, before you close any js bug please make sure that you have enabled strict
javascript warnings inside about:config.

=> Reopening
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Updated

14 years ago
Summary: Dozends of javascript warnings during start of Firefox in nsExtensionManager.js → Dozens of javascript strict warnings during start of Firefox in nsExtensionManager.js
It would have helped if you'd mentioned it so that others can reproduce it.

anyway, now I can CONFIRM ;-)
a truckload of errors in jsconsole if javascript.options.strict is set true

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803
Firefox/0.9.1+

Comment 5

14 years ago
Shouldn't this be a duplicate of bug 249012
(Reporter)

Comment 6

14 years ago

*** This bug has been marked as a duplicate of 249012 ***
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

13 years ago
v
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.