The default bug view has changed. See this FAQ.

Can't add feeds when offline or Network down

RESOLVED FIXED in Thunderbird 24.0

Status

MailNews Core
Feed Reader
--
minor
RESOLVED FIXED
13 years ago
4 years ago

People

(Reporter: Nickolay_Ponomarev, Assigned: alta88)

Tracking

unspecified
Thunderbird 24.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

4.30 KB, patch
alta88
: review+
Details | Diff | Splinter Review
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040730 Firefox/0.9.1+ (best browser EVAR1!!)
Build Identifier: Thunderbird 0.7+ (20040730)

When adding an RSS feed via Subscribe to feeds dialog, Thunderbird tries to
verify the feed, fails because the link is not available, and does not add the
feed to feeds list.

Reproducible: Always
Steps to Reproduce:
1. Create an RSS account
2. Click Subscribe to feeds
3. Click Add, try to add http://www.mozillazine.org/atom.xml
Actual Results:  
"<...> could not be found" error message is shown, the feed is not added.

Expected Results:  
The feed is added, verification is delayed until connection is available (maybe
the feed should be verified when it's first checked for items?)

This doesn't work neither when TB thinks it is online but there's no connection,
nor when TB is in offline state. It is very inconvenient to copy my feeds from
another RSS reader, since I will have to be online just to add my feeds to the list.

This is with version 0.7+ (20040730), dialup connection on WinXP.

Comment 1

13 years ago
post 1.0...
Target Milestone: --- → After Thunderbird 1.

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: rss
Dan, David,  ENH, bug or wonfix?  (bug was confirmed by dougweb)
Assignee: mscott → nobody
Severity: normal → minor
Summary: Can't add feeds when offline → Can't add feeds when offline or Network down
ENH or bug, 6 of one, half a dozen of the other.  Worth doing in any case...
Severity: minor → normal

Updated

8 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
Severity: normal → minor
Target Milestone: Future → ---
(Assignee)

Comment 4

4 years ago
Created attachment 763276 [details] [diff] [review]
patch


1. if subscribing, and offline, the standard prompt will appear to download messages; if 'Go Online' is declined, the feed url is added anyway without validation, which can be done once online on next biff or manually.
2. also fixes Bug 687428.
Assignee: nobody → alta88
Attachment #763276 - Flags: review?(mkmelin+mozilla)
(Assignee)

Updated

4 years ago
Blocks: 687428

Comment 5

4 years ago
Comment on attachment 763276 [details] [diff] [review]
patch

Review of attachment 763276 [details] [diff] [review]:
-----------------------------------------------------------------

Sure, r=mkmelin

::: mailnews/extensions/newsblog/content/Feed.js
@@ +140,5 @@
>  
> +    if (Services.io.offline) {
> +      // If offline and don't want to go online, just add the feed subscription;
> +      // it can be verified later (the folder name will be the url if not adding
> +      // to an existing folder).  Only for subscribe actions; passive biff and

no double spacing please
Attachment #763276 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Comment 6

4 years ago
Created attachment 763739 [details] [diff] [review]
for checkin
Attachment #763276 - Attachment is obsolete: true
Attachment #763739 - Flags: review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
OS: Windows XP → All
Hardware: x86 → All
https://hg.mozilla.org/comm-central/rev/88b7851495c4
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 24.0
You need to log in before you can comment on or make changes to this bug.