Resize expands JS/JPEG pix endlessly

VERIFIED FIXED in M5

Status

()

P2
major
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: Michael.Mulchek, Assigned: vidur)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
Using the nightly 1-21-99 binary of Win32 Mozilla, or any others prior for that
matter, when starting up the SlideShow JS test included with the Mozilla source
code, I noticed that resizing the window using the corner tab expands the
picture by a pixel or so every time the window is resized a pixel or so.  The
dogs just keep getting bigger and bigger and bigger.  Evil!
This is not happening with regular JPEG images or GIF images, only this
javascript slideshow.  If this is known or not a bug, or the show is just not
written correctly or finished, sorry, it's just wierd. Thanks.

file://C|/MozillaSource/mozilla/layout/html/tests/SlideShow/show.html
(Reporter)

Comment 1

20 years ago
This behavior might be dependant on how often the window/display is asked to
refresh itself.  If the Win98 option of "View Contents while dragging/resizing
a window" is on, the window is asked to redraw once every time anything is
resized, even before the new window size is committed to.  If the option is not
on, it takes longer for the effect to be noticed because it's only redrawing
once.

Comment 2

20 years ago
Setting all current Open Critical and Major to M3

Comment 3

20 years ago
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser

Comment 4

20 years ago
DOM bugs are not my problem.

Updated

20 years ago
Component: JavaScript → Layout

Comment 5

20 years ago
Sorry for sitting on this one so long, I thought it could be a mozilla classic
bug... but it's still with us.  I tried it out on todays daily build under
apprunner, and it still occurs.

Takes a few resizes to see that the picture is getting bigger, but it is, by
about a pixel per resize.  I'm forwarding it to the layout module.

Thanks for spotting this -
Mike

Updated

20 years ago
Assignee: mccabe → troy

Updated

20 years ago
QA Contact: 4015 → 1698

Comment 6

20 years ago
QA contact re-assigned to Imaging owner.

Updated

20 years ago
QA Contact: 1698 → 4015

Comment 7

20 years ago
I've investigated this (moved files to a public URL that doesn't require checking
out files), and have some opinions:

* I can't reproduce this problem using the 3.10.99 builds on Mac OS or Win32.
(Tried Apprunner & Viewer.)

* It's probably not an imaging bug, since the author points out that it works
outside of the JavaScript. (CC:ing pnunn for confirmation.)

* I do note a related crashing bug (probably unrelated). Will write up
separately.

Thus, reassigning back to Gerardo. (Thanks for passing it over.)

Comment 8

20 years ago
I've investigated this (moved files to a public URL that doesn't require checking
out files), and have some opinions:

* I can't reproduce this problem using the 3.10.99 builds on Mac OS or Win32.
(Tried Apprunner & Viewer.)

* It's probably not an imaging bug, since the author points out that it works
outside of the JavaScript. (CC:ing pnunn for confirmation.)

* I do note a related crashing bug (probably unrelated). Will write up
separately.

Thus, reassigning back to Gerardo. (Thanks for passing it over.)

Updated

20 years ago
Target Milestone: M3 → M4

Comment 9

20 years ago
troy/pam, is this a bug for pnunn?

Comment 10

20 years ago
From what I can see, the images alone display fine.
The bug appears to be in js or layout.
-pn

Updated

20 years ago
Assignee: troy → vidur
Component: Layout → DOM Level 0

Comment 11

20 years ago
When I view the images alone, I don't see the problem mentioned, so maybe it's
js related.

Unfortunately, if I try and load "show.html" nothing happens (the animation is
going, but the page never loads)
(Assignee)

Updated

20 years ago
Target Milestone: M4 → M5
(Assignee)

Comment 12

20 years ago
*** Bug 2364 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 13

20 years ago
Not a problem anymore. I believe fixed by Kipp's recent set of image changes.
Note that the test specified needs to be modified to use the setAttribute method
instead of setDOMAttribute. In the meantime, use the test in
mozilla/layout/html/tests/SlideShow/show.html

Updated

20 years ago
Status: RESOLVED → VERIFIED
QA Contact: gerardok → gem

Comment 14

20 years ago
verified
You need to log in before you can comment on or make changes to this bug.