Ctrl+* shortcuts don't work in the Find toolbar - of note, Ctrl+V, Ctrl+Backspace

RESOLVED FIXED in mozilla1.8rc1

Status

()

RESOLVED FIXED
14 years ago
10 years ago

People

(Reporter: jhatax, Assigned: masayuki)

Tracking

unspecified
mozilla1.8rc1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040725 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040725 Firefox/0.9

Ctrl+* shortcuts don't work in the Find toolbar since the Find field does not
have a cursor (but keyboard input gets directed to it). Clicking the field with
the mouse presents the user with a cursor after which all keyboard shortcuts
related to text entry work fine.

Reproducible: Always
Steps to Reproduce:
1. Start typing - the find toolbar appears
2. Try pasting text with Ctrl+V

Actual Results:  
No text gets pasted.

Expected Results:  
Text should get pasted since this is the default behaviour of a textfield. Also
other keyboard data entry shortcuts should work.
see bug 253988 comment 1
OS: Windows XP → All

Comment 2

14 years ago
Like bug 253988, this is invalid. It's not supposed to have focus in TAF mode.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 3

14 years ago
FAYT could support Ctrl+V and Ctrl+Backspace without the Find bar having focus,
and IMO it should support at least Ctrl+V.
Status: RESOLVED → REOPENED
Depends on: 257489
Resolution: INVALID → ---
This is fixed by bug 259454.(It's Fx only, not including SeaMonkey)
Assignee: firefox → masayuki
Status: REOPENED → NEW
Depends on: 259454
No longer depends on: 257489
Hardware: PC → All
Target Milestone: --- → Firefox1.5rc1
-> FIXED
Status: NEW → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → FIXED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.