Auto- width resize of Iframe fails with Absolute positioning

RESOLVED INVALID

Status

()

Core
Layout: HTML Frames
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Simon Anthony, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

Auto- width resize of Iframe fails with Absolute positioning

The test files show that auto width resizing of an iframe works in

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8 
(and recent Netscape releases and IE6)

but fails from

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614
Firefox/0.8	FAIL

and still fails with

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707
Firefox/0.9.2	FAIL



<html>
<head>
<meta http-equiv="content-type" content="text/html; charset=iso-8859-1">
<style>
.example
{	position:absolute;
	background-color:green;}
</style>
</head>
<body>
      	<div class=example>
				<iframe width=100% height=100%

					src="content.txt"
					>

				</iframe>
		</div>
</body>
</html>



the content file can be just ---
    lorem ipsum dolor sit amet, nunc volutpat nunc, ultrices ac magna
consectetuer ante. sagittis tellus faucibus vel pharetra dui. condimentum
feugiat, etc...








Reproducible: Always
Steps to Reproduce:
1.create files as in details
2.dusplay in browser :>
3.

Actual Results:  
In bugged browser auto-resize of the iframe width does not happen.

Expected Results:  
It should resize with browser window size dynamically - it used to - netscape
and IE still do.

I know this is not a full QA report - I have got tired!

I am available for paid QA work by the way...
Simon, thank you for the bug report!

> it used to

That was a bug (bug 97695 to be precise).  The bug has been fixed.

In this case, the layout should be the same no matter whether the iframe width
is "100%" or "auto", since its containing block has shrink-wrap width.  Which is
exactly the behavior current builds have.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.