### ASSERTION: RemoveElementsAt(negative index)

RESOLVED DUPLICATE of bug 224643

Status

()

RESOLVED DUPLICATE of bug 224643
14 years ago
14 years ago

People

(Reporter: darin.moz, Unassigned)

Tracking

({qawanted})

Trunk
x86
Linux
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
visit http://www.newegg.com/ in a trunk build, and you will hit the assertion 
"RemoveElementsAt(negative index)" inside nsVoidArray::RemoveElementsAt.

here's a stack trace leading up to the assertion:

#2  0x08080af3 in nsDebug::Assertion (
    aStr=0x4b3cb4 "RemoveElementsAt(negative index)", aExpr=0x4b3c0f "aIndex >= 0",
    aFile=0x4b3bdc "/builds/moz-trunk/mozilla/xpcom/ds/nsVoidArray.cpp", aLine=561)
    at nsDebug.cpp:108
#3  0x0041fe09 in nsVoidArray::RemoveElementsAt (this=0xa4c180c, aIndex=-1,
aCount=1)
    at /builds/moz-trunk/mozilla/xpcom/ds/nsVoidArray.cpp:561
#4  0x0516fd04 in nsContentIterator::PositionAt (this=0xa4c17f0, aCurNode=0xa5b4af8)
    at /builds/moz-trunk/mozilla/content/base/src/nsContentIterator.cpp:1134
#5  0x0516f663 in nsContentIterator::Last (this=0xa4c17f0)
    at /builds/moz-trunk/mozilla/content/base/src/nsContentIterator.cpp:987
#6  0x05278ea5 in nsHTMLAnchorElement::GetText (this=0xa5b4af8, aText=@0xfeec7d40)
    at
/builds/moz-trunk/mozilla/content/html/content/src/nsHTMLAnchorElement.cpp:503
#7  0x00499601 in XPTC_InvokeByIndex ()

further down the stack is nsDocShell::EndPageLoad.
Minimal testcase would be nice here...
Keywords: qawanted

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 224643 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.