autocomplete="off" cannot be set using javascript

RESOLVED INVALID

Status

()

Core
DOM: Core & HTML
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: Adrian Yee, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

Using javascript to set the autocomplete="off" form property doesn't work in
Firefox (and I'm assuming Mozilla in general).  However, setting
autocomplete="off" in the form, does disable autocompletion.

Reproducible: Always
Steps to Reproduce:
Turn on autocomplete in Firefox/Mozilla, and submit the form.
Actual Results:  
autocomplete is not disabled

Expected Results:  
autocomplete should be disabled.  Click on the link at the bottom to see correct
behaviour.
You're setting the _property_, whereas you should be setting the _attribute_
(using setAttribute()).

Not all attributes are mapped into properties; in particular, any attributes
that are not part of standard HTML are NOT mapped into properties.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
*** Bug 273911 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.