If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

creative.com - form on webpage not being populated

RESOLVED INCOMPLETE

Status

Tech Evangelism Graveyard
English US
RESOLVED INCOMPLETE
13 years ago
3 years ago

People

(Reporter: Bob Kirsch, Unassigned)

Tracking

Details

(Whiteboard: [bug248549fixed], URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

Hi. I noticed that when I went to download updated software for my mp3 player
from Creative Labs at http://us.creative.com/support/downloads/, this URL was
not loading the selections into the page (1. Select your product).  I had to
exit Firefox and launch I.E - it works fine there.  Cannot get it to work with
Firefox 0.9.3.

Thanks.

Reproducible: Always
Steps to Reproduce:
1. Go to URL.  You will see that item 1. Select Your Product is blank.
2. Attempt with I.E. and you will see it is populated.
3.

Actual Results:  
Field is blank.

Expected Results:  
Load the selection list from the vendor website.

Comment 1

13 years ago
I think it's trying to use the IE DOM model where you can call any element in JS
just by using it's "name" or "id" attribute (for example,
"onChange="populateFamilies(driver_search.MainCategory.options[driver_search.MainCategory.selectedIndex].value);"").
 Firefox/Gecko doesn't support this way of calling elements, I believe.

Comment 2

13 years ago
Er, I should've added that this should be moved to Tech Evangelism, if my
comment is indeed true.
(Reporter)

Comment 3

13 years ago
(In reply to comment #1)
> I think it's trying to use the IE DOM model where you can call any element in JS
> just by using it's "name" or "id" attribute (for example,
>
"onChange="populateFamilies(driver_search.MainCategory.options[driver_search.MainCategory.selectedIndex].value);"").
>  Firefox/Gecko doesn't support this way of calling elements, I believe.

OK, so I'm new at this here, are there plans for adding this support to the
product?  I just hoped that this product could be the catchall replacement for
IE for me, and I hate to think that I would need to switch from this back to IE
to get to a specific website.  Is there another forum or process that I need to
request this support to be added, or will this be added somethow to a list?


Thanks,
Bob 

Comment 4

13 years ago
this works for me with Win XP Firefox branch build 2004-08-18-08-0.9
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> this works for me with Win XP Firefox branch build 2004-08-18-08-0.9

Yes, I also downloaded the latest nightly release - 0.9.1+, and it works fine. 
It does NOT work with 0.9.3, the reported release I had installed, so that
indicates to me that it is a BUG or DESIGN change in the releases, correct???  

Also, is the "nightly" release that you indicated above what I just downloaded??
branch build 2004-08-18-08-0.9?? How do I tell if this is the same???

Thanks,

Bob 

Comment 6

13 years ago
document.all support (which applies to this, I think) was recently checked in.
Hence why it works. In light of that, this really, really needs to be moved to
Tech Evangelism now.

Updated

13 years ago
Status: UNCONFIRMED → NEW
Component: Form Manager → English US
Ever confirmed: true
OS: Windows XP → All
Product: Firefox → Tech Evangelism
Hardware: PC → All
Summary: Form on webpage not being populated. → creative.com - form on webpage not being populated
Whiteboard: [bug248549fixed]

Updated

13 years ago
Assignee: bugs → english-us
QA Contact: form-manager → english-us

Comment 7

7 years ago
INCOMPLETE due to lack of activity since the end of 2009.

If someone is willing to investigate the issues raised in this bug to determine whether they still exist, *and* work with the site in question to fix any existing issues, please feel free to re-open and assign to yourself.

Sorry for the bugspam; filter on "NO MORE PRE-2010 TE BUGS" to remove.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.