An <iframe> tag inside a <arrowscrollbox> crashes the browser [@ nsView::GetDimensions ]

RESOLVED DUPLICATE of bug 38589

Status

()

--
critical
RESOLVED DUPLICATE of bug 38589
15 years ago
8 years ago

People

(Reporter: aerton, Unassigned)

Tracking

({crash})

Trunk
x86
Windows 2000
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

An <iframe> tag inside a <arrowscrollbox> crashes the browser.

It crashes when a XUL is loaded from chrome, local file, or a web server.

Reproducible: Always
Steps to Reproduce:
The following XUL crashes the browser

<?xml version="1.0"?>
<?xml-stylesheet href="chrome://softomate_toolbar/content/style.css"
type="text/css"?>

<window
    id="toolbar-window"
    title="Toolbar"
    orient="horizontal"
    xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"
    align="center">

<arrowscrollbox orient="horizontal" flex="1">
        <iframe width="80" src="http://www.mozilla.org/"/>
</arrowscrollbox>

</window>


Actual Results:  
browser crashes

Expected Results:  
display the page

Comment 1

15 years ago
Ilya: Could you provide TalkBack incident ID of your crash?
Keywords: crash
(Reporter)

Comment 2

15 years ago
Created attachment 155263 [details]
talkback dump

I do not know how to get the icident ID send by talkback, I only can say that I
had included id of the bug (254415) into the description.

I'm including the talkback dump into the attachment.

Comment 3

15 years ago
(In reply to comment #2)
> I do not know how to get the icident ID send by talkback, I only can say that I
> had included id of the bug (254415) into the description.
Open/run Talkback.exe to see the incident ID. From the start menue group of
Firefox or from [FF_Program_Path]\firefox\components\talkback.exe.

With that ID you can view the whole stack at
http://talkback-public.mozilla.org/talkback/fastfind.jsp
Or you can search for specific comments.

Comment 4

15 years ago
To get the Talkback ID's go to your Firefox directory and go to components/,
there start talkback.exe, it'll give you a list with the IDs. Thank's a lot.
(Reporter)

Comment 5

15 years ago
the icident id is
nsView::GetDimensions 1e2f735b

Comment 6

15 years ago
TB488313:
nsView::GetDimensions 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/view/src/nsView.h,
line 248]
nsView::GetClippedRect 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/view/src/nsView.cpp,
line 841]
nsViewManager::UpdateView 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/view/src/nsViewManager.cpp,
line 1738]
nsViewManager::MoveViewTo 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/view/src/nsViewManager.cpp,
line 2567]
nsContainerFrame::PositionFrameView 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 510]
nsBox::SetBounds 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsBox.cpp,
line 584]
nsSprocketLayout::Layout 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsSprocketLayout.cpp,
line 484]
nsContainerBox::DoLayout 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsContainerBox.cpp,
line 610]
nsBox::Layout 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsBox.cpp,
line 994]
nsBox::Layout 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsBox.cpp,
line 994]
nsContainerBox::DoLayout 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsContainerBox.cpp,
line 610]
nsBox::Layout 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsBox.cpp,
line 994]
nsContainerBox::DoLayout 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsContainerBox.cpp,
line 610]
nsBox::Layout 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsBox.cpp,
line 994]
nsContainerBox::DoLayout 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsContainerBox.cpp,
line 610]
nsBox::Layout 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsBox.cpp,
line 994]
nsRootBoxFrame::Reflow 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsRootBoxFrame.cpp,
line 240]
nsContainerFrame::ReflowChild 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
ViewportFrame::Reflow 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsViewportFrame.cpp,
line 249]
PresShell::InitialReflow 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 2827]
nsXULDocument::StartLayout 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/content/xul/document/src/nsXULDocument.cpp,
line 2197]
nsXULDocument::ResumeWalk 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/content/xul/document/src/nsXULDocument.cpp,
line 3050]
nsXULDocument::EndLoad 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/content/xul/document/src/nsXULDocument.cpp,
line 746]
XULContentSinkImpl::DidBuildModel 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/content/xul/document/src/nsXULContentSink.cpp,
line 460]

Looks like dupe of bug 38589.

*** This bug has been marked as a duplicate of 38589 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Summary: An <iframe> tag inside a <arrowscrollbox> crashes the browser → An <iframe> tag inside a <arrowscrollbox> crashes the browser [@ nsView::GetDimensions ]

Comment 7

15 years ago
Bug 35299 should be also related (same signature/stack, more similar description).

Updated

11 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.widgets
Crash Signature: [@ nsView::GetDimensions ]
You need to log in before you can comment on or make changes to this bug.