Installer does not cleanup Add/Remove list when performing an upgrade

VERIFIED DUPLICATE of bug 247884

Status

()

VERIFIED DUPLICATE of bug 247884
15 years ago
13 years ago

People

(Reporter: thorin.geo, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

When performing and upgrade (installing one version over another) the previous
add/remove programs entery(ies) are not removed from the registry. This causes
1) The old entries to break. 2) Clutter and confusion.

Reproducible: Always
Steps to Reproduce:
1. Install some version of Firefox. (ie: 0.9.0)
2. Install another version of Firefox (upgrade) (ie: 0.9.1)


Actual Results:  
There are now two enteries (or more depending on your upgrade cycle etc)
displayed in the Add/Remove programs control panel.

This causes 1) The old entries to break. 2) Clutter and confusion.

Expected Results:  
The old Add/Remove entry(ies) should have been purged from the registry so that
only the latest entry exists.

I've replicated this issue on Win2K and WinXP (Home & Pro). THis prolem has
existed in all versions of Firefox that I've installed since 0.8.9 (IIRC that
was my first) up to 0.9.3 which I upgraded to this morning.

I'm very sorry if this bug has already been listed but I was unable to search
the bug db to see if this was already found and submitted as our corporate
firewall doesn't like something in your search process/pages (tried multiple).
'WatchGuard firewall: Response denied from
http://207.126.111.200:80/buglist.cgi: Unsafe content type
"multipart/x-mixed-replace"'

*** This bug has been marked as a duplicate of 247884 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.