Thunderbird BiDi support in composer

RESOLVED DUPLICATE of bug 96057

Status

defect
RESOLVED DUPLICATE of bug 96057
15 years ago
15 years ago

People

(Reporter: mozilla, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla Thunderbird 0.7.1 (X11/20040626)

We need BiDi support in Thunderbird's message composer. When composing a
plaintext message in Arabic (Hebrew or any RTL language), there is no way to
change the direction to RTL, English and Arabic paragraphs all show up
left-to-right.

The only workaround right now is composing an HTML message, and changing dir
attributes to RTL, this requires using the Page Color and Background dialog to
set the dir attribute to ltr, which isn't that straight forward for the average
user.


Reproducible: Always
Steps to Reproduce:
1. Open the compose window in Thunderbird.
2. Type something in Arabic.

Actual Results:  
Arabic text shows up left-to-right.

Expected Results:  
There should be a way to change direction to right-to-left, even when composing
a plaintext message.

Received plaintext messages that are in Arabic should show up right-to-left too,
or at least there should be a way to change this.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 96057 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.