Reload on a stopped form submission re-submits the form.

VERIFIED WORKSFORME

Status

()

Core
Document Navigation
P2
normal
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: Adam Masri, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build ID: 2000012601 (M13)
Platform: Macintosh PowerBook G3/300, MacOS 9, 128Mb RAM, VM off.

First, go to any random page on the 'Net. Then, go to the Bugzilla search system

http://bugzilla.mozilla.org/query.cgi

Type in any search. After hitting Submit Query, immediately hit Stop. Now, hit
Reload in Moz. Why does it try to resubmit the previous search? It should reload
the search form again, since that's the page you stopped on. Back shouldn't take
you to the Query page, Back should take you to the page you were viewing before
the Query page.

- Adam

Comment 1

18 years ago
in bug 18038 radha mentioned that s/he would open a new bug for proper history 
handling. My guess is s/he knows what bug this is a duplicate of. So assinging 
to radha. Radha: could you update bug 18038 per claudius' request?
Assignee: nobody → radha
Component: Browser-General → History

Comment 2

18 years ago
Bill, can we fix this by beta 1?
Assignee: radha → law
Severity: minor → normal
Priority: P3 → P2
Target Milestone: M14

Comment 3

18 years ago
This might depend on landing the new session history code (or more precisely, 
the new webshell code that uses it).  I'm reassigning this to Radha (even those 
she's not here) so I can better organize my bug lists.  I am monitoring here M14 
bugs (and then her M15's when we get to that point).
Assignee: law → radha
Status: NEW → ASSIGNED
This is related to removing user stopped and illegal urls out of SH. Currently
successful and unsuccessful loads get in to SH since we don't have a way of
distinguishing how a load became unsuccessful. Marking this dependant on 20068
Depends on: 20068
Target Milestone: M14 → M15
re-summarized
Summary: Back, Reload buttons not going to correct URLs → Reload on a stopped form submission re-submits the form.

Comment 6

18 years ago
Move to M16 for now ...
Target Milestone: M15 → M16

Comment 7

18 years ago
I'm resolving this bug as WFM. I checked with the 2000042109 builds and i don't believe it to be a problem anymore in light of 
the new webshell and SH changes.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
OS: Mac System 9.0 → All
QA Contact: nobody → claudius
Hardware: Macintosh → All
Resolution: --- → WORKSFORME

Comment 8

18 years ago
marking VERIFIED WFM, please reopen if you can reproduce with a current build
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.