If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Help -> About Mozilla does nothing

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Daniel Nash, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040803 WebWasher 3.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040803 WebWasher 3.3

After intalling Mozilla 1.7.2 over selecting Help -> About Mozilla from the main
menus causes the hourglass next to the mouse pointer, as if something is about
to happen, but nothing does. Closing Mozilla does not then kill the mozilla.exe
process (maybe the "About" window is there but not visible?).

Reproducible: Always
Steps to Reproduce:
1. Choose Help -> About from the main menu
2.
3.

Actual Results:  
Nothing

Expected Results:  
Shown a window with the mozilla logo and userAgent string (which is what I was
trying to find to show that my install of 1.7.2 had succeeded).

I have UltraVNC installed. Mozilla 1.7.2 was intalled as a user with admin
priveleges over Moz 1.7.1.

Comment 1

13 years ago
--> XP Apps? Not really 100% sure where this should go, so if I'm wrong,
reassign elsewhere. I know that this should definetely not be under help.
Assignee: rlk → jag
Component: Help → XP Apps
QA Contact: daniel.bugmail → pawyskoczka

Comment 2

13 years ago
About: needs javascript enabled to show the user agent. I´ve seen bugs about
About: showing the old user agent. That happened because some extension
(Multizilla?) hadn´t been deinstalled.

Please create a new profile, just for test, without extensions, just to see that
about: is working.

As told in the Release Notes, Mozilla shouldn´t be installed ontop of a previous
one. With a plain vanilla Mozilla, sometimes installing ontop is working, but
there is no warranty, and chances are high installed extensions will break your
installation.
Installing ontop doesn´t remove the GRE.

Do you use themes or extensions? 
I didn´t find documentation about UltraVNC on sourceforge, only some screenshots
how to install. Do you need a browser for running the UltraVNC viewer?

I would recommend deinstalling your current Mozilla, and then reinstalling it.
How did you install ontop? Unpacking a zip, or using an exe installer, or using
the net installer?
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> About: needs javascript enabled to show the user agent. I�ve seen bugs about
> About: showing the old user agent. That happened because some extension
> (Multizilla?) hadn�t been deinstalled.

I had javascript enabled but popups blocked. I found that no new windows were
ever launched no matter what setting I chose for popup blocking after I reported
this bug. Opening in new tabs worked fine.

> Please create a new profile, just for test, without extensions, just to see that
> about: is working.
> 

I'm sorry, I had urgent work to complete on a Javascript project, so I ended up
deinstalling, clearing \Documents and Settings\<username>\Application
Data\Mozilla and reinstalling - which fixed the problem.

I suspect my profile was screwed somehow but I can't do the test now.

> As told in the Release Notes, Mozilla shouldn�t be installed ontop of a previous
> one. With a plain vanilla Mozilla, sometimes installing ontop is working, but
> there is no warranty, and chances are high installed extensions will break your
> installation.
> Installing ontop doesn�t remove the GRE.

Thanks for pointing this out - getting the correct and complete version is
important to me because I am testing client-side code against the various releases.

> Do you use themes or extensions? 

No. I have LiveHTTPHeaders installed sometime ago but I believe that was nuked
in an earlier install.

> I didn�t find documentation about UltraVNC on sourceforge, only some screenshots
> how to install. Do you need a browser for running the UltraVNC viewer?

UltraVNC (in the mode I am using it) requires a display driver - which I have
seen some systems interpret as a second screen - I was thinking maybe this was
confusing the OS into sending the window to the wrong 'screen'.

> I would recommend deinstalling your current Mozilla, and then reinstalling it.

Have done and problem is now fixed, but that may have been due to me clearing
the Documents and Setting\<username>\Application Data\Mozilla directory.

> How did you install ontop? Unpacking a zip, or using an exe installer, or using
> the net installer?

.exe installer

Comment 4

13 years ago
(In reply to comment #3)
 
> I had javascript enabled but popups blocked. I found that no new windows were
> ever launched no matter what setting I chose for popup blocking after I reported
> this bug. Opening in new tabs worked fine.
> 

> > As told in the Release Notes, Mozilla shouldn�t be installed ontop of a
previous
> > one. With a plain vanilla Mozilla, sometimes installing ontop is working, but
> > there is no warranty, and chances are high installed extensions will break your
> > installation.
> > Installing ontop doesn�t remove the GRE.
> 
> Thanks for pointing this out - getting the correct and complete version is
> important to me because I am testing client-side code against the various
releases.
> 
> > Do you use themes or extensions? 
> 
> No. I have LiveHTTPHeaders installed sometime ago but I believe that was nuked
> in an earlier install.

I wouldn´t recommend using one profile only for testing all Mozilla versions.
Maybe there is code on a release that fixes the profile for use with a newer
version, but I doubt the profile would then be working fine with an older
version. I had some trouble when I installed a really old 0.8.x version of
Mozilla (Not Firefox!). I´ve got one main profile I mostly use with the current
nightly, sometimes with 1.7.x or 1.4.x, mostly I´m starting them with own
profiles, edited the shortcuts 
mozilla.exe -ProfileManager or mozilla.exe -P "myprofilename"
I´m often installing LiveHTTPheaders 0.8, had to deinstall manually
LiveHTTPheaders 0.9 as it was running only once.
useful links:
http://www.alain.knaff.lu/~aknaff/howto/MozillaCustomization/cgi/readMoz.cgi
http://www.holgermetzger.de/efaqgeneral.html
http://kb.mozillazine.org/
http://kb.mozillazine.org/index.phtml?title=Profile_Folder

Comment 5

13 years ago
Resolving worksforme according to reporter´s comment #3:

> deinstalling, clearing \Documents and Settings\<username>\Application
  Data\Mozilla and reinstalling - which fixed the problem
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.