components don't get updated when selecting products in reports

RESOLVED FIXED in Bugzilla 2.20

Status

()

Bugzilla
Reporting/Charting
RESOLVED FIXED
14 years ago
6 years ago

People

(Reporter: Albert Ting, Assigned: Christian Reis)

Tracking

2.19
Bugzilla 2.20

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040707 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040707 Firefox/0.8

Select a product in the tabular reports does not update the components. 

Reproducible: Always
Steps to Reproduce:
Click on reports -> tabular.  Then click on a product.  The components don't get
updated. 



The changes in bug #123030 has the doOnSelectProduct() function called in
form.html.tmpl, and defined in search-advanced.html.tmpl.

However, that breaks report tables/graphs because both search-report-table.html
 and search-report-graph.html now needs to have doOnSelectProduct() locally defined.

I thought moving the doOnSelectProduct() definition into form.html.tmpl would
work, but the table/graph templates uses a different syntax.  In fact, I don't
think the table/graph templates areloading any .js file (productmenu.js or
productform.js).  Also confused why there is both a productmenu.js and a
productform.js
(Reporter)

Updated

14 years ago
Version: unspecified → 2.19

Updated

14 years ago
Assignee: gerv → kiko
(Assignee)

Comment 1

14 years ago
Yeah. It's my fault. And you're right -- what the hell is productmenu.js? That
needs some serious declunkifying :-)
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

14 years ago
I ended fixing this to complete a feature I'm trying to get approved for (bug
#224208). Hopefully I am going in the right direction. 
(Reporter)

Comment 3

14 years ago
The patch in bug #224208 resolves this bug, so this can be marked closed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Target Milestone: --- → Bugzilla 2.20
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.