Occasional blank calendar display at startup with javascrip errors

RESOLVED INVALID

Status

Calendar
Sunbird Only
--
major
RESOLVED INVALID
14 years ago
12 years ago

People

(Reporter: René Seindal, Assigned: Mostafa Hosseini)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040704 Firefox/0.8
Build Identifier: Calendar 2004080311 in Mozilla Thunderbird 0.7.1 (20040715)

Since I installed the 2004080311 build every so often the calendar opens with a
blank display.  My calendars are there, but no events or tasks are displayed. 
It doesn't happen every time, but maybe one in two.

Javascript errors below.

My workaround is to reinstal the xpi and restart thunderbird and calendar, and
the calendar inevitably comes up correctly the next time.

I had the previous version of calendar installed, and just installed this one on
top, assuming it would work since its the same extension.  I have since tried to
uninstall and install the calendar extension several times, in an attempt at
clearing the setup.

I cannot exclude that the problem is because of a messed up installation due to
the installation over the old version.

Reproducible: Sometimes
Steps to Reproduce:
1. Open Thunderbird
2. Open Calendar in Thunderbird

Actual Results:  
Sometimes the display is blank, except for the list of my calendars

Expected Results:  
Displayed my events and tasks

The Javascript console in Thunderbird has this when the calendar display is
blank.  There is nothing when it opens correctly.

Error: [Exception... "Component returned failure code: 0x80004001 
(NS_ERROR_NOT_IMPLEMENTED) [oeIICalTodo.completed]"  nsresult: 
"0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame :: 
chrome://calendar/content/unifinderToDo.js :: toDoUnifinderRefresh :: 
line 148"  data: no]
Source File: chrome://calendar/content/unifinderToDo.js
Line: 148

Error: [Exception... "Component returned failure code: 0x80004001 
(NS_ERROR_NOT_IMPLEMENTED) [oeIICalTodo.completed]"  nsresult: 
"0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame :: 
chrome://calendar/content/unifinderToDo.js :: toDoUnifinderRefresh :: 
line 148"  data: no]
Source File: chrome://calendar/content/unifinderToDo.js
Line: 148

Error: [Exception... "Component returned failure code: 0x80004001 
(NS_ERROR_NOT_IMPLEMENTED) [oeIICalEvent.getNextRecurrence]"  nsresult: 
"0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame :: 
chrome://calendar/content/unifinder.js :: getNextOrPreviousRecurrence :: 
line 746"  data: no]
Source File: chrome://calendar/content/unifinder.js
Line: 746

Error: [Exception... "Component returned failure code: 0x80004001 
(NS_ERROR_NOT_IMPLEMENTED) [oeIICalTodo.completed]"  nsresult: 
"0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame :: 
chrome://calendar/content/unifinderToDo.js :: toDoUnifinderRefresh :: 
line 148"  data: no]
Source File: chrome://calendar/content/unifinderToDo.js
Line: 148

Error: uncaught exception: [Exception... "Component returned failure 
code: 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [oeIICalTodo.completed]" 
nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame 
:: chrome://calendar/content/calendarEvent.js :: 
calEvent_getToDosForRange :: line 531"  data: no]

Comment 1

14 years ago
The javascript errors might be a version mismatch.

As of 20040804 and later, the calendar xpi includes the install.rdf file so that
the firefox and thunderbird extension managers install the Calendar extension in
the profile directory instead of in the application directory.  Since it doesn't
overwrite the old version, the new code may conflict with the old code still
installed in the application directory.  You can try the uninstall instructions
in the faq.  Or completely uninstall thunderbird and delete the application
directory, then reinstall fresh.  If that doesn't work, also try a new profile
(maybe by renaming the old profile directory).
(Reporter)

Comment 2

14 years ago
I think this problem is solved, thanks to gekacheka@yahoo.com.

I uninstalled thunderbird from my system, manually removed what ever files were
left behind, which happened to have names containing the word 'calendar', and
reinstalled thunderbird again.

I have not seen the problem since then.

If this is a bug, it is in the installation guide for calendar in thunderbird on
linux.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: gurganbl → sunbird
You need to log in before you can comment on or make changes to this bug.