Last Comment Bug 254564 - Buddy icons not shown
: Buddy icons not shown
Status: RESOLVED FIXED
: fixed1.8, regression
Product: SeaMonkey
Classification: Client Software
Component: MailNews: Message Display (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: ---
Assigned To: mail
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-06 04:26 PDT by M.J.G.
Modified: 2005-09-19 16:27 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch to abCardViewOverlay.js (Checked in) (677 bytes, patch)
2004-08-06 04:33 PDT, M.J.G.
mozilla: review+
mozilla: superreview+
mtschrep: approval1.8b5+
Details | Diff | Splinter Review
patch to msgHdrViewOverlay.js (Checked in) (799 bytes, patch)
2004-08-06 04:35 PDT, M.J.G.
mozilla: review+
mozilla: superreview+
mtschrep: approval1.8b5+
Details | Diff | Splinter Review

Description M.J.G. 2004-08-06 04:26:18 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040805 Firefox/0.9.3
Build Identifier: Mozilla Thunderbird 0.7.2 (X11/20040716)

Mailnews/Thunderbird should display buddy icons as described in
http://www.mozilla.org/mailnews/arch/buddyicons.html, i.e. they should show uop
in message view (headers expanded) and card view (addressbook).
Alas, nothing is shown.

Reproducible: Always
Steps to Reproduce:
1. Set up buddy icons (icons and addressbook card) as per
http://www.mozilla.org/mailnews/arch/buddyicons.html
2. Call up message view (expanded) or address card.
3. 

Actual Results:  
No buddy icons are visible. No visual difference to the case without buddy icons.

Expected Results:  
Display buddy icons.

Same in cvs.
Comment 1 M.J.G. 2004-08-06 04:30:52 PDT
Digging into abCardViewOverlay.js, I noticed that a call to XPCOM's directory
service is wrong ("@mozilla.org/directory_service;1" instead of
"@mozilla.org/file/directory_service;1"). The attached patch is a one liner, it
works for me in the addressbook. The patch is against the version from TBird's
0.7.2 source tar ball, but I checked that the current version is still missing
the "/file" part.

The same one-liner as for abCardView works for msgHdrView and implements the
correct behaviour for the message header view.
Comment 2 M.J.G. 2004-08-06 04:33:59 PDT
Created attachment 155353 [details] [diff] [review]
patch to abCardViewOverlay.js
(Checked in)

patch to abCardViewOverlay.js from content/messenger/addressbook in mail.jar
Comment 3 M.J.G. 2004-08-06 04:35:30 PDT
Created attachment 155354 [details] [diff] [review]
patch to msgHdrViewOverlay.js (Checked in)

patch to msgHdrViewOverlay.js from content/messenger in mail.jar
Comment 4 M.J.G. 2004-08-06 04:40:52 PDT
This affects components "Mail Window Fron End" and "Addressbook". How do I
specify two components?
Comment 5 Ian Neal 2005-09-18 10:55:03 PDT
Comment on attachment 155353 [details] [diff] [review]
patch to abCardViewOverlay.js
(Checked in)

Changing to someone who will r/sr on mailnews
Comment 6 Ian Neal 2005-09-18 10:55:44 PDT
Comment on attachment 155354 [details] [diff] [review]
patch to msgHdrViewOverlay.js (Checked in)

Changing to someone who will r/sr on mailnews
Comment 7 Ian Neal 2005-09-18 13:43:14 PDT
Checking in (trunk)
base/resources/content/msgHdrViewOverlay.js; new revision: 1.142; previous
revision: 1.141
addrbook/resources/content/abCardViewOverlay.js; new revision: 1.37; previous
revision: 1.36
done
Comment 8 Ian Neal 2005-09-18 13:58:27 PDT
Comment on attachment 155353 [details] [diff] [review]
patch to abCardViewOverlay.js
(Checked in)

requesting a= for simple, low risk, regression fix
Comment 9 Ian Neal 2005-09-18 13:58:44 PDT
Comment on attachment 155354 [details] [diff] [review]
patch to msgHdrViewOverlay.js (Checked in)

requesting a= for simple, low risk, regression fix
Comment 10 Mike Schroepfer 2005-09-19 15:15:48 PDT
Comment on attachment 155354 [details] [diff] [review]
patch to msgHdrViewOverlay.js (Checked in)

Approved for 1.8b5 per bug meeting
Comment 11 Ian Neal 2005-09-19 16:27:17 PDT
Checking in (branch)
addrbook/resources/content/abCardViewOverlay.js; new revision: 1.36.26.1;
previous revision: 1.36
base/resources/content/msgHdrViewOverlay.js; new revision: 1.141.2.1; previous
revision: 1.141
done

Note You need to log in before you can comment on or make changes to this bug.