OnChange of a SELECT component is not invoked while changing active option with keyboard

VERIFIED DUPLICATE of bug 126379

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 126379
13 years ago
13 years ago

People

(Reporter: Theocharis Athanasakis, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.8

Granted that an OnChange JavaScript client-side function is assigned to a SELECT
HTML component, the browser should invoke the JavaScript function *everytime*
the active OPTION of the SELECT is changed (at least this is what MSIE
6.0.2800.1106.xpsp2 does). However, FireFox 0.9.3, neglects to invoke the
function if the OPTION is changed using the keyboard (aka pressing the Up or
Down arrow) while the function is invoked if you change the value using the mouse.

Reproducible: Always
Steps to Reproduce:
1. On the supplied URL, http://afros.irc.gr/?go=map, try changing the action
OPTION of the first listbox using the mouse (that is dropping down the list box
and selecting an item by clicking it). The second listbox is shown or hidden
according to your choice -- that is the OnSelect is invoked.
2. Now try to set the focus on the listbox and change the active element using
*only* the keyboard (a method commonly used). Nothing happens -- that is the
OnSelect is not invoked, albeit it should.
Actual Results:  
Explained above.

Expected Results:  
Explained above.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.