If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

delayed window.open doesn't work

RESOLVED INVALID

Status

SeaMonkey
General
--
major
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Hish, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707

<img onmouseover="a=setTimeout("window.open('http://www.google.com')",500)"
onmouseout="clearTimeout(a)">
Result: Moz1.5 opened a popup after 0.5 secs. Moz1.7/FF0.9 don't.

Reproducible: Always
Steps to Reproduce:
> <img onmouseover="a=setTimeout("

invalid nesting of quotes. this can't have ever worked.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

13 years ago
You're right. I didn't copy/paste but just typed the example.
So here we go again:
<script>
var a;
function o() {
window.open('http://www.google.com');
}
</script>
<div onmouseover="a=setTimeout('o()',500)"
     onmouseout="clearTimeout(a)">aaaaa</div>

Anyway, in the meantime did some tests. It also doesn't work on 1.5 when this is
within a html page. The difference between 1.5 and 1.7 is that the example above
worked in xul pages (replacing the div by a xul element of course).
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
hm, interesting...
do you happen to have popup blocker enabled?
do you get any messages in javascript console?
(Reporter)

Comment 4

13 years ago
> do you happen to have popup blocker enabled?
Yes
> do you get any messages in javascript console?
No
well, then I'm pretty sure the behaviour is by design. an onmouseover popup is
not really requested. danm?
(Reporter)

Comment 6

13 years ago
Repace onmouseover by onclick and you'll get the same result.

Comment 7

13 years ago
It'd be a pretty crummy popup blocker if it didn't stop window.open from timers.
The only issue here is why previous versions might have failed to stop the open,
and frankly I'm inclined to doubt that. Some extensions cause the popup blocker
injury; I suspect your builds that do allow this window also have one of these
extensions.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

13 years ago
> It'd be a pretty crummy popup blocker if it didn't stop window.open from timers.
You're right. I have to agree.
> The only issue here is why previous versions might have failed to stop the open,
> and frankly I'm inclined to doubt that.
It worked up to 1.6
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.