Very long delay launching Mozilla when corp-wide custom homepage is down/offline/broken

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Edgar, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040616

In a corp-setup (mozilla deployed via msi) I override the startup.homepage for
all users in Progs-Folder\Mozilla\defaults\pref\browser-prefs.js to point to
Intranet-Server. 

If Intranet-Server happens to be down (web-server process hangs) startup of
Mozilla takes aproximatly 5 minutes, showing only the splash-screen and giving
no feedback whatsoever on what it is waiting for.

This only happens if the Intranet-Server accepts the tcp-connection, but then
does not respond. If Intranet-Server rejects the tcp-connection, mozilla
lanuches, showing a blank page. If Intranet-Server responds with an
error-condition, Mozilla displays it. If however the tcp-connection just sits
there idle, Mozilla waits until it times out.

Reproducible: Always
Steps to Reproduce:
1. take random-box and launch "nc -lp 8080" (netcat)
2. add >>pref("browser.startup.homepage", "http://random-box:8080/");<< to
Mozilla\defaults\pref\browser-prefs.js
3. delete any "browser.startup.hompage"-entry from Profile\prefs.js
4. lauch Mozilla and enjoy a 5 minutes wait until tcp times out getting no
visual feedback
I don't think this does what you want it to... since this preference is read as
a localized pref, that url will be downloaded synchronously, and tried to be
interpreted as name=value pairs... blocking the UI thread.

much better would be to change the appropriate file in US.jar...

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.