Unable to display saved .htm file in Offline Mode (Online Mode without connection works)

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Stebs, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.1+ (MOOX-AV)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.1+ (MOOX-AV)

When our (forced) proxy server went down, I experienced another bug (FF
completely freezes with an proxy set, so I had to manually edit prefs.js to set
it to "Work offline"
Then tried to open a previously saved FAQ for a game but it wouldnt load. 

Reproducible: Always
Steps to Reproduce:
1.Go to the url above
2.Save the Page as Web Page, html only
3.Unplug your network connection/modem etc.
4.Set Browser to "Work Offline"
5.Close it and doublecklick on the saved .htm file 

Actual Results:  
The Webpage cannot be loaded (just some light Backgroundcolor)

Expected Results:  
The Webpage should be loaded entirely

When "Work offline" is unset, the Webpage is shown correctly even with still no
connection.
Dont know if there are other Webpages that dont work, just stumbled on this by
coincidence.

Comment 1

13 years ago
However why do pages that I have viewed a few days back not visible after a few
days - Any setting that any of you are aware of ?
Conjectures - Once you close the browser or the OS does it erase the cache on
opening next time and where is the cache kept ?
Please tell me - I have completely shifted to FireFox from the crashy IE 6.0 -
However this thing is nagging me ...
I get an error message when I try to open a viewed page later; after I have
closed the browser ... and started it again in the next session or after
restarting the PC
Summary: Unable to display saved .htm file in Offline Mode (Online Mode without connection works) → Unable to display saved .htm file in Offline Mode (Online Mode without connection works)

Comment 2

13 years ago
Even Though I have set firefox as my default net application, still saved pages
open up by default in MS_IE only.However on right clicking a saved file and then
using open with ..firefox, some pages open up correctly(the ones with only basic
HTML stuff open up real easily). However this is not the case with most pages
and most of them do not open up from their saved offline versions.
(Reporter)

Comment 3

13 years ago
Gonna clean up and mark this WFM since it works now with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050715
Firefox/1.0+ ID:2005071506
and it was UNCONFIRMED all the time anyway...
(Dont know if it works with 1.0x Versions)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.