Can not set a global default-homepage

RESOLVED EXPIRED

Status

()

RESOLVED EXPIRED
14 years ago
12 years ago

People

(Reporter: bugs-mozilla, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040805 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040805 Firefox/0.9.3

I am trying to setup a company-specific startup-homepage on a lot of
clients. I tried to to add

| pref("browser.startup.homepage", "http://my-company.com");

to /usr/lib/firefox-0.9.3/defaults/pref/00options.js.

about:config shows that this setting was accepted, but when pressing the
'home' button, firefox goes to http://www.mozilla.org/products/firefox/


Other settings in the file above are working as expected (e.g. proxy),
and only the 'browser.startup.homepage' preference will be ignored.


What am I doing wrong, and what can I do to configure the default
homepage?


Reproducible: Always
Steps to Reproduce:
1. echo 'pref("browser.startup.homepage", "http://my-company.com");' >>usr/lib/firefox-0.9.3/defaults/pref/00options.js
2. start firefox with a new profile/empty configuration
3. press 'home' button

Actual Results:  
http://www.mozilla.org/products/firefox/ appears

Expected Results:  
http://my-company.com appears

Mozilla shows the same broken behavior
(Reporter)

Comment 1

14 years ago
Another strange thing: when setting 'http://my-company.com' as homepage in the
local user-preferences dialog (Edit->Preferences->General/Location(s)), firefox
will still go to 'http://www.mozilla.org/products/firefox/'.

When using a slightly different string (e.g. appending a '/'), things are ok again.

The whole thing seems to be locale-dependent; after using the german
languagepack, firefox will assume 'http://firebird-browser.de/' as the homepage.


This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → EXPIRED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.