calling a helper or saving a url is freezes the browser for 2-5 seconds [delay,start,slow]

RESOLVED DUPLICATE of bug 159107

Status

Core Graveyard
File Handling
RESOLVED DUPLICATE of bug 159107
14 years ago
2 years ago

People

(Reporter: Spiros Ioannou, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a2) Gecko/20040714
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a2) Gecko/20040714

Generally, saving something like an image takes much longer than displaying it
in the browser, due to a delay after pressing the "Save" button which freezes
the browser for a few seconds.
The same problem can be seen by saving a file with "content-disposition" header,
or by clicking on a link that requires a helper to be called (like an mp3
player). There is always a delay which gives an overall impression of slowness.
This is regardless of whether the download manager, the progress window, or no
window is shown during download.




Reproducible: Always
Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
I forgot to mention, that Netscape 4 (or IE) doesn't have this issue, so if it
is some temp-file locking issue there must be a faster way of doing it.
Probably the usual issue with a huge downloads.rdf...
Whiteboard: DUPEME

*** This bug has been marked as a duplicate of 159107 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.