If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

text input focus change delayed when opening a new browser tab

VERIFIED DUPLICATE of bug 218216

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 218216
13 years ago
13 years ago

People

(Reporter: Marc Bejarano, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

the text input focus automatically chages to the location bar when a new tab is
created with CTRL-T, but there is a delay such that text can be entered in the
old focused are.

Reproducible: Always
Steps to Reproduce:
1. select a small ammount of text and copy it to the clipboard
2. place your input focus in a form field such as the "Additional Comments" area
above
3. hit CTRL-t to open a new tab
4. immediately type CTRL-v repeatedly to paste your selection.  soon, you will
be pasting in the location bar for the new tab and you can stop.
Actual Results:  
if you go back to the original browser tab, you should see your selection pasted
in the form field one or more times.

Expected Results:  
all of the pasted text should end up in the new location bar.

Comment 1

13 years ago
Mozilla 1.7.2
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040803

I have found a similar problem. When loading a site that has an input box that
receives focus (assuming onload javascript), the focus will be given to that
input regardless of which tab you are in. Example is loading gmail.google.com
and then switching to another tab. I can even press enter from another tab and
it submits my username/password.
MikeB: That is bug 245502.

*** This bug has been marked as a duplicate of 218216 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.